aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vincent <freesilicon@gmail.com>2017-01-04 17:43:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-09 13:39:12 +0000
commitc9e21f0266cc742ba8b47ea3bd49cfb63b9f797b (patch)
tree490ee866d080273bc2831ab171f6d80b4252fa86
parentbfdc6f565d8f828c8fa97897eec366f057021942 (diff)
downloadopenembedded-core-contrib-c9e21f0266cc742ba8b47ea3bd49cfb63b9f797b.tar.gz
nss: Fix postinstall script
When installing NSS on a read-only rootfs, the current postinstall scriptlet exits after having run the signing part. This causes an error when appending the task because the rest of the script is simply ignored and therefore never run. (From OE-Core rev: 8f782f7095e718dd9452055af53363beb6bdbece) Signed-off-by: David Vincent <freesilicon@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/nss/nss_3.27.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-support/nss/nss_3.27.1.bb b/meta/recipes-support/nss/nss_3.27.1.bb
index 091793899f..a69672b3d8 100644
--- a/meta/recipes-support/nss/nss_3.27.1.bb
+++ b/meta/recipes-support/nss/nss_3.27.1.bb
@@ -208,18 +208,18 @@ do_install_append_class-target() {
pkg_postinst_${PN} () {
if [ -n "$D" ]; then
- for I in $D/${libdir}/lib*.chk; do
+ for I in $D${libdir}/lib*.chk; do
DN=`dirname $I`
BN=`basename $I .chk`
FN=$DN/$BN.so
shlibsign -i $FN
- if [ $? -ne 0 ]; then
- exit 1
- fi
+ if [ $? -ne 0 ]; then
+ exit 1
+ fi
done
- exit 0
+ else
+ signlibs.sh
fi
- signlibs.sh
}
PACKAGES =+ "${PN}-smime"