aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-08-31 15:15:55 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-08 00:36:48 +0100
commit4da96ce61f92cfa22f85ae38435cbb57bce17dd6 (patch)
tree4ff96eee10332aebc6b3c2f6b72a5c5fb4165338
parent39d3aa28283d763bbc4aadcbb040f038a506a6df (diff)
downloadopenembedded-core-contrib-4da96ce61f92cfa22f85ae38435cbb57bce17dd6.tar.gz
recipetool: create: AX_PKG_SWIG should add dependency on swig-native
If AX_PKG_SWIG is found in configure.ac, then what's being looked for is the swig binary, not swig for the target - so fix the dependency accordingly. (From OE-Core rev: 2600cd6f6c63ecf79804e2bc6eb6f198a012d5d6) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--scripts/lib/recipetool/create_buildsys.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/recipetool/create_buildsys.py b/scripts/lib/recipetool/create_buildsys.py
index f784f9468a..0ad748ef02 100644
--- a/scripts/lib/recipetool/create_buildsys.py
+++ b/scripts/lib/recipetool/create_buildsys.py
@@ -570,7 +570,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
elif keyword == 'AX_LIB_TAGLIB':
deps.append('taglib')
elif keyword == 'AX_PKG_SWIG':
- deps.append('swig')
+ deps.append('swig-native')
elif keyword == 'AX_PROG_XSLTPROC':
deps.append('libxslt-native')
elif keyword == 'AX_WITH_CURSES':