aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2012-12-17 17:56:26 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-16 15:59:05 +0000
commitd0858ccb33a68d4bd2b34159e71bb2489f9c4728 (patch)
tree5d52f7634218c54a0631624c2b5a291cce270c57
parent6833ec86ac84d24e05ed3712f6cfcdb38a4dd01a (diff)
downloadopenembedded-core-contrib-d0858ccb33a68d4bd2b34159e71bb2489f9c4728.tar.gz
kernel-dev: Updates to get the new kernel-dev manual to make
These changes were to the intro chapter to introduce the DocBook form, the Makefile to introduce the new manual, the figure used for the title had to be updated, the root manual .XML file needed changed, and the style sheet. The manual now makes with just the raw text for Darren's intro section. (From yocto-docs rev: 1bceb7bdd4fe5773c11c7ddbdae00554680bbf6d) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--documentation/Makefile14
-rw-r--r--documentation/kernel-dev/figures/kernel-dev-title.pngbin27810 -> 13453 bytes
-rw-r--r--documentation/kernel-dev/kernel-dev-intro.xml101
-rw-r--r--documentation/kernel-dev/kernel-dev-style.css37
-rw-r--r--documentation/kernel-dev/kernel-dev.xml2
5 files changed, 86 insertions, 68 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 1ab74fc61a..7c3d16ec04 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -235,6 +235,20 @@ FIGURES = figures
STYLESHEET = $(DOC)/*.css
endif
+ifeq ($(DOC),kernel-dev)
+XSLTOPTS = --stringparam html.stylesheet kernel-dev-style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = kernel-dev.html kernel-dev.pdf kernel-dev-style.css figures/kernel-dev-title.png
+MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
+FIGURES = figures
+STYLESHEET = $(DOC)/*.css
+endif
+
##
# These URI should be rewritten by your distribution's xml catalog to
diff --git a/documentation/kernel-dev/figures/kernel-dev-title.png b/documentation/kernel-dev/figures/kernel-dev-title.png
index 1cb989f34a..7a8dd54372 100644
--- a/documentation/kernel-dev/figures/kernel-dev-title.png
+++ b/documentation/kernel-dev/figures/kernel-dev-title.png
Binary files differ
diff --git a/documentation/kernel-dev/kernel-dev-intro.xml b/documentation/kernel-dev/kernel-dev-intro.xml
index c1cc22bb7a..68fac80ac7 100644
--- a/documentation/kernel-dev/kernel-dev-intro.xml
+++ b/documentation/kernel-dev/kernel-dev-intro.xml
@@ -2,76 +2,79 @@
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd"
[<!ENTITY % poky SYSTEM "../poky.ent"> %poky; ] >
-<chapter id='kernel-doc-intro'>
+<chapter id='kernel-dev-intro'>
-<title>Yocto Project Kernel Architecture and Use Manual</title>
+<title>Yocto Project Kernel Development Manual</title>
-<section id='kernel-intro-section'>
+<section id='kernel-dev-introduction'>
<title>Introduction</title>
+
<para>
- The Yocto Project presents kernels as a fully patched, history-clean Git
- repositories.
- Each repository represents selected features, board support,
- and configurations extensively tested by the Yocto Project.
- Yocto Project kernels allow the end user to leverage community
- best practices to seamlessly manage the development, build and debug cycles.
+ Regardless of how you intend to make use of the Yocto Project, chances are you
+are going to need to work with the Linux kernel. The Yocto Project provides a
+powerful set of tools for managing Linux kernel sources and configuration data.
+If you want to make a single configuration change, apply a couple of patches, or
+work with your own sources, the Yocto Project has tooling in place to help you
+do it.
</para>
+
<para>
- This manual describes Yocto Project kernels by providing information
- on history, organization, benefits, and use.
- The manual consists of two sections:
- <itemizedlist>
- <listitem><para><emphasis>Concepts:</emphasis> Describes concepts behind a kernel.
- You will understand how a kernel is organized and why it is organized in
- the way it is. You will understand the benefits of a kernel's organization
- and the mechanisms used to work with the kernel and how to apply it in your
- design process.</para></listitem>
- <listitem><para><emphasis>Using a Kernel:</emphasis> Describes best practices
- and "how-to" information
- that lets you put a kernel to practical use.
- Some examples are how to examine changes in a branch and how to
- save kernel modifications.</para></listitem>
- </itemizedlist>
+ Each Yocto Project release introduces a new set of linux-yocto kernel recipes,
+tracking the latest upstream developments and introducing newly supported
+platforms. In addition to the new kernel recipes, the previous recipes are
+refreshed and supported for at least one additional release. As they align,
+these previous releases are updated to include the latest from the LTSI project.
+Besides these recipes, a linux-yocto-dev recipe is available for working with
+the very latest in upstream Linux kernel development as well as meta-data
+development.
</para>
<para>
- For more information on the Linux kernel, see the following links:
- <itemizedlist>
- <listitem><para>The Linux Foundation's guide for kernel development
- process - <ulink url='http://www.linuxfoundation.org/content/1-guide-kernel-development-process'></ulink></para></listitem>
- <listitem><para>A fairly encompassing guide on Linux kernel development -
- <ulink url='http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob_plain;f=Documentation/HOWTO;hb=HEAD'></ulink></para></listitem>
- </itemizedlist>
+ If you do not maintain your own kernel sources and need to make only minimal
+changes to the sources, these recipes provide a vetted base upon which to layer
+your changes. Doing so allows you to benefit from the continual kernel
+integration and testing performed during development of the Yocto Project.
</para>
<para>
- For more discussion on the Yocto Project kernel, you can see these sections
- in the Yocto Project Development Manual:
+ If, instead, you have a very specific Linux kernel source tree and are unable to
+align with one of the many official linux-yocto releases, an alternative
+exists by which you can use the Yocto Project Linux kernel tools with your own
+sources.
+ </para>
+
+ <para>
+ The sections that follow provide instructions for completing specific Linux
+kernel development tasks. They assume familiarity with working with bitbake
+recipes and basic open-source development tools. Understanding these concepts
+will facilitate the process of working with the kernel recipes. If you find you
+need some additional background, please be sure to review and understand the
+following documentation:
<itemizedlist>
- <listitem><para>
- "<ulink url='&YOCTO_DOCS_DEV_URL;#kernel-overview'>Kernel Overview</ulink>"</para></listitem>
- <listitem><para>
- "<ulink url='&YOCTO_DOCS_DEV_URL;#kernel-modification-workflow'>Kernel Modification Workflow</ulink>"
+ <listitem><para><emphasis>Yocto Project Quick Start</emphasis>
</para></listitem>
- <listitem><para>
- "<ulink url='&YOCTO_DOCS_DEV_URL;#patching-the-kernel'>Patching the Kernel</ulink>"</para></listitem>
- <listitem><para>
- "<ulink url='&YOCTO_DOCS_DEV_URL;#configuring-the-kernel'>Configuring the Kernel</ulink>"</para></listitem>
+ <listitem><para><emphasis>Yocto Project Development Manual</emphasis>
+ <itemizedlist>
+ <listitem><para><emphasis>4.3 Modifying Temporary Source Code</emphasis>
+ </para></listitem>
+ <listitem><para><emphasis>5.1 Understanding and Creating Layers</emphasis>
+ </para></listitem>
+ <listitem><para><emphasis>4.1.2 Modifying the Kernel</emphasis>
+ (This section should be retired, as well as 5.6, 5.7 - with this document
+ providing the necessary information)</para></listitem>
+ </itemizedlist></para></listitem>
</itemizedlist>
</para>
<para>
- For general information on the Yocto Project, visit the website at
- <ulink url='&YOCTO_HOME_URL;'></ulink>.
+ Finally, while this document focuses on the manual creation of recipes, patches,
+and configuration files, the Yocto Project BSP tools are available to automate
+this process with existing content and work well to create the initial framework
+and boilerplate code. For details, refer to the Yocto Project BSP Developer's
+Guide.
</para>
</section>
-
-
-
-
-
-
</chapter>
<!--
vim: expandtab tw=80 ts=4
diff --git a/documentation/kernel-dev/kernel-dev-style.css b/documentation/kernel-dev/kernel-dev-style.css
index a90d4af291..52be14388d 100644
--- a/documentation/kernel-dev/kernel-dev-style.css
+++ b/documentation/kernel-dev/kernel-dev-style.css
@@ -1,6 +1,6 @@
-/*
+/*
Generic XHTML / DocBook XHTML CSS Stylesheet.
-
+
Browser wrangling and typographic design by
Oyvind Kolas / pippin@gimp.org
@@ -42,7 +42,7 @@
body {
font-family: Verdana, Sans, sans-serif;
-
+
min-width: 640px;
width: 80%;
margin: 0em auto;
@@ -118,7 +118,7 @@ h6 {
background-color: transparent;
background-repeat: no-repeat;
padding-top: 256px;
- background-image: url("figures/kernel-title.png");
+ background-image: url("figures/kernel-dev-title.png");
background-position: left top;
margin-top: -256px;
padding-right: 50px;
@@ -243,7 +243,7 @@ div.legalnotice p.legalnotice-title {
p {
line-height: 1.5em;
margin-top: 0em;
-
+
}
dl {
@@ -297,7 +297,7 @@ p a[id] {
padding: 0px;
display: inline;
background-image: none;
-}
+}
a {
text-decoration: underline;
@@ -338,10 +338,10 @@ div.table p.title b{
font-weight: normal;
}
-.mediaobject .caption,
+.mediaobject .caption,
.mediaobject .caption p {
text-align: center;
- font-size: 80%;
+ font-size: 80%;
padding-top: 0.5em;
padding-bottom: 0.5em;
}
@@ -604,7 +604,7 @@ b.keycap,
.keycap {
border: 1px solid;
}
-
+
div.navheader, div.heading{
border-bottom: 1px solid;
@@ -675,10 +675,10 @@ hr {
}
.note {
- background-color: #f0f0f2;
+ background-color: #f0f0f2;
}
-.glossary dl dt,
+.glossary dl dt,
.variablelist dl dt,
.variablelist dl dt span.term {
color: #044;
@@ -778,10 +778,10 @@ div.article .titlepage .title
}
*/
-div.preface .titlepage .title,
-div.colophon .title,
+div.preface .titlepage .title,
+div.colophon .title,
div.chapter .titlepage .title,
-div.article .titlepage .title
+div.article .titlepage .title
{
}
@@ -942,8 +942,8 @@ table {
.tip,
.note {
- background: #f0f0f2;
- color: #333;
+ background: #f0f0f2;
+ color: #333;
padding: 20px;
margin: 20px;
}
@@ -954,12 +954,12 @@ table {
margin: 0em;
font-size: 2em;
font-weight: bold;
- color: #333;
+ color: #333;
}
.tip a,
.note a {
- color: #333;
+ color: #333;
text-decoration: underline;
}
@@ -976,4 +976,3 @@ table {
font-size:large;
color: #00557D;
}
-
diff --git a/documentation/kernel-dev/kernel-dev.xml b/documentation/kernel-dev/kernel-dev.xml
index 82a9e2ff5c..ab8f45366c 100644
--- a/documentation/kernel-dev/kernel-dev.xml
+++ b/documentation/kernel-dev/kernel-dev.xml
@@ -59,6 +59,7 @@
<xi:include href="kernel-dev-intro.xml"/>
+<!--
<xi:include href="kernel-dev-common.xml"/>
<xi:include href="kernel-dev-advanced.xml"/>
@@ -66,6 +67,7 @@
<xi:include href="kernel-dev-examples.xml"/>
<xi:include href="kernel-dev-faq.xml"/>
+-->
<!-- <index id='index'>
<title>Index</title>