aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2014-11-13 09:23:04 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-17 15:16:57 +0000
commitcd31b931e39d9adde8dbbb8de53e097a4c58f50b (patch)
treeeef1c536f401d8e8fb41d693c8b66f69fe4346e6
parent430237631e9a480413445646d6c130b4fdb90fff (diff)
downloadopenembedded-core-contrib-cd31b931e39d9adde8dbbb8de53e097a4c58f50b.tar.gz
documentation: Support files to build Toaster Manual.
Changes to the files that support building out and publishing the Toaster User Manual: * poky.ent - Added a new variable YOCTO_DOCS_TOAST_URL that can be used in other manuals to link to sections with the Toaster User Manual. * Makefile - Added a section of code to build out the Toaster User Manual. Currently, no eclipse support is added as I don't think we want to cross into that development environment with Toaster. (From yocto-docs rev: 35ea6656265d61024d5db36a534a7250f783956a) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--documentation/Makefile39
-rw-r--r--documentation/poky.ent1
2 files changed, 28 insertions, 12 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 3735faf8a5..9957935e17 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -1,7 +1,13 @@
-# This is a single Makefile to handle all generated Yocto Project documents.
-# The Makefile needs to live in the documentation/ directory and all figures
-# used in any manuals must be .PNG files and live in the individual book's
-# figures/ directory as well as in the figures/ directory for the mega-manual.
+# This is a single Makefile to handle all generated Yocto Project documents,
+# which includes the BitBake User Manual and the Toaster User Manual.
+# The Makefile needs to live in the documents directory and all figures used
+# in any manuals must be .PNG files and live in the individual book's figures
+# directory as well as in the figures directory for the mega-manual.
+#
+# Some manuals are available as linked help through the Eclipse development
+# system. These manuals also include an "eclipse" sub-directory as part of
+# the make process.
+#
# Note that the figures for the Yocto Project Development Manual
# differ depending on the BRANCH being built.
#
@@ -65,17 +71,17 @@
#
# Examples:
#
-# make publish DOC=bsp-guide VER=1.3
-# make publish DOC=adt-manual VER=1.3
+# make publish DOC=bsp-guide VER=1.7
+# make publish DOC=adt-manual VER=1.6
# make publish DOC=dev-manual VER=1.1.1 BRANCH=edison
# make publish DOC=dev-manual VER=1.2 BRANCH=denzil
#
-# The first example publishes the 1.3 version of both the HTML version
-# of the BSP Guide. The second example publishes the 1.3 version of the
-# HTML version of the YP Application Developer's Guide. The third example publishes
-# the HTML 'edison' versions of the YP Development Manual and, if applicable, the
-# Eclipse version. The fourth example publishes the HTML 'denzil' version and,
-# if applicable, the Eclipse version of the YP Development Manual.
+# The first example publishes the 1.7 version of both the PDF and HTML versions of
+# the BSP Guide. The second example publishes the 1.6 version of both the PDF and
+# HTML versions of the ADT Manual. The third example publishes the 1.1.1 version of
+# the PDF and HTML YP Development Manual for the 'edison' branch. The fourth example
+# publishes the 1.2 version of the PDF and HTML YP Development Manual for the
+# 'denzil' branch.
#
ifeq ($(DOC),bsp-guide)
@@ -319,6 +325,15 @@ FIGURES = figures
STYLESHEET = $(DOC)/*.css
endif
+ifeq ($(DOC),toaster-manual)
+XSLTOPTS = --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = toaster-manual.html toaster-manual.pdf toaster-manual-style.css figures/toaster-title.png
+MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
+FIGURES = figures
+STYLESHEET = $(DOC)/*.css
+endif
+
##
# These URI should be rewritten by your distribution's xml catalog to
diff --git a/documentation/poky.ent b/documentation/poky.ent
index 6a791db742..2d5bd38a2c 100644
--- a/documentation/poky.ent
+++ b/documentation/poky.ent
@@ -52,6 +52,7 @@
<!ENTITY YOCTO_DOCS_PROF_URL "&YOCTO_DOCS_URL;/&YOCTO_DOC_VERSION;/profile-manual/profile-manual.html">
<!ENTITY YOCTO_DOCS_MM_URL "&YOCTO_DOCS_URL;/&YOCTO_DOC_VERSION;/mega-manual/mega-manual.html">
<!ENTITY YOCTO_DOCS_BB_URL "&YOCTO_DOCS_URL;/&YOCTO_DOC_VERSION;/bitbake-user-manual/bitbake-user-manual.html">
+<!ENTITY YOCTO_DOCS_TOAST_URL "&YOCTO_DOCS_URL;/&YOCTO_DOC_VERSION;/toaster-manual/toaster-manual.html">
<!ENTITY YOCTO_ADTPATH_DIR "/opt/poky/&DISTRO;">
<!ENTITY YOCTO_POKY_TARBALL "&YOCTO_POKY;.tar.bz2">
<!ENTITY OE_INIT_PATH "&YOCTO_POKY;/oe-init-build-env">