aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Mueller <timo.mueller@bmw-carit.de>2012-11-30 09:59:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-14 17:21:29 +0000
commit239b4698202d702067213cb64146ec4676b835c7 (patch)
tree2986f803e1f689e91bf38f60985704b035a4a312
parenta11f23b4bc743f1240b75d43dff397d562ae56de (diff)
downloadopenembedded-core-contrib-239b4698202d702067213cb64146ec4676b835c7.tar.gz
documentation/Makefile: Added conversion of links to other documentation parts.
The script tools/eclipse-help.sed is used to convert links that point to other documentation parts. This avoids having to leave the eclipse help center when clicking these links. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--documentation/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 13b85af159..b27d2f32f1 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -316,7 +316,11 @@ endif
eclipse: BASE_DIR = html/$(DOC)/
-eclipse:
+eclipse: eclipse-generate eclipse-resolve-links
+
+.PHONY : eclipse-generate eclipse-resolve-links
+
+eclipse-generate:
ifeq ($(filter $(DOC), adt-manual bsp-guide dev-manual kernel-manual poky-ref-manual yocto-project-qs),)
@echo " "
@echo "ERROR: You can only create eclipse documentation"
@@ -342,9 +346,19 @@ else
$(DOC)-eclipse-customization.xsl $(DOC).xml && \
mv eclipse/toc.xml eclipse/$(DOC)-toc.xml && \
cp -rf $(FIGURES) eclipse/$(BASE_DIR)/$(FIGURES) && \
- cd ..
+ cd ..;
+
+ $(call modify-eclipse)
endif
+eclipse-resolve-links:
+ @echo " "
+ @echo "******** Using eclipse-help.sed to process external links"
+ @echo " "
+ $(foreach FILE, \
+ $(wildcard $(DOC)/eclipse/html/$(DOC)/*.html), \
+ $(shell sed -i -f tools/eclipse-help.sed $(FILE)))
+
tarball: html
@echo " "
@echo "******** Creating Tarball of document files"