aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-04-07 14:49:44 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-09 23:00:44 +0100
commitaa45c75df989302ba8ae9deaf136b0046f0b4f84 (patch)
treea6e4285cc32e7a883462023eb9f0ae9acad2987f
parentd366a3319e7e938b4e24362db96562bc0d336cf7 (diff)
downloadopenembedded-core-contrib-aa45c75df989302ba8ae9deaf136b0046f0b4f84.tar.gz
x11-common: Add PACKAGECONFIG for screen blanking
when "blank" is not in PACKAGECONFIG, explicitly set dpms and screensaver off. The intention here is to make it easier to create builds that should not blank the screen (just remove "blank" from x11-common PACKAGECONFIG). Also remove a unneeded "find -exec rm" from do_install. Partly fixes [YOCTO #7278]. (From OE-Core rev: 32ac0bfb0167cb350be5d4b8faca490956dd7d93) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/x11-common/x11-common/Xserver.in (renamed from meta/recipes-graphics/x11-common/x11-common/etc/X11/Xserver)2
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb9
2 files changed, 9 insertions, 2 deletions
diff --git a/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xserver b/meta/recipes-graphics/x11-common/x11-common/Xserver.in
index 73570dfeb50..b8eed7610fa 100644
--- a/meta/recipes-graphics/x11-common/x11-common/etc/X11/Xserver
+++ b/meta/recipes-graphics/x11-common/x11-common/Xserver.in
@@ -5,7 +5,7 @@ XSERVER=/usr/bin/Xorg
. /etc/profile
-ARGS=" -br -pn"
+ARGS=" -br -pn @BLANK_ARGS@"
DISPLAY=':0'
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
index 156b329486a..6d7c347c001 100644
--- a/meta/recipes-graphics/x11-common/x11-common_0.1.bb
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -9,14 +9,21 @@ inherit distro_features_check
REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI = "file://etc \
+ file://Xserver.in \
file://gplv2-license.patch"
S = "${WORKDIR}"
+PACKAGECONFIG ??= "blank"
+# dpms and screen saver will be on only if 'blank' is in PACKAGECONFIG
+PACKAGECONFIG[blank] = ""
+
do_install() {
cp -R ${S}/etc ${D}${sysconfdir}
+ sed -e 's/@BLANK_ARGS@/${@bb.utils.contains('PACKAGECONFIG', 'blank', '', '-s 0 -dpms', d)}/' \
+ ${S}/Xserver.in > ${D}${sysconfdir}/X11/Xserver
+
chmod -R 755 ${D}${sysconfdir}
- find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
}
RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"