aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-04-30 22:01:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-24 08:53:56 +0100
commit71a4bf386181b3fbc2dc723c781a456a0bbdb943 (patch)
treee7f767a74a9152f51466baa4e6846199080f4fb0
parentbdb158594f83790ea207a3e6b1708faa722d4b74 (diff)
downloadopenembedded-core-contrib-71a4bf386181b3fbc2dc723c781a456a0bbdb943.tar.gz
qemumachines: Enable xserver-xorg as default xserver
For qemux86 and qemux86-64 include qemu.inc after defining XSERVER XSERVER variable is also weakly defined in task-core-x11.bb which means we can not use ??= otherwise when building any qemu image that uses task-core-x11.bb will get the wrong definition So we define the XSERVER common set for qemu in qemu.inc and as we know x86 and x86-64 qemu overrides the default we include qemu.inc after that definition which means that qemux86 and qemux86-64 get their own definitions and other qemus get the definitions from qemu.inc. other non-qemu machine will get their defintion from task which points to kdrive as of now. (From OE-Core rev: 62dba36166bc5faa32ba3e0664ae98b168cde6b1) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/conf/machine/include/qemu.inc9
-rw-r--r--meta/conf/machine/qemux86-64.conf3
-rw-r--r--meta/conf/machine/qemux86.conf3
3 files changed, 12 insertions, 3 deletions
diff --git a/meta/conf/machine/include/qemu.inc b/meta/conf/machine/include/qemu.inc
index 421a14925b..e384879a8f 100644
--- a/meta/conf/machine/include/qemu.inc
+++ b/meta/conf/machine/include/qemu.inc
@@ -1,7 +1,14 @@
PCMCIA_MANAGER = "pcmciautils"
-PREFERRED_PROVIDER_virtual/xserver ?= "xserver-kdrive"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/libgl ?= "mesa-xlib"
+XSERVER ?= "xserver-xorg \
+ mesa-dri-driver-swrast \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard"
+
MACHINE_FEATURES = "apm alsa pcmcia bluetooth irda usbgadget screen"
IMAGE_FSTYPES += "tar.bz2 ext3"
diff --git a/meta/conf/machine/qemux86-64.conf b/meta/conf/machine/qemux86-64.conf
index 129fe9f282..2e361a5cab 100644
--- a/meta/conf/machine/qemux86-64.conf
+++ b/meta/conf/machine/qemux86-64.conf
@@ -6,7 +6,6 @@ PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
require conf/machine/include/tune-x86_64.inc
-require conf/machine/include/qemu.inc
MACHINE_FEATURES += "x86"
@@ -23,6 +22,8 @@ XSERVER ?= "xserver-xorg \
xf86-video-vmware \
qemugl"
+require conf/machine/include/qemu.inc
+
GLIBC_ADDONS = "nptl"
GLIBC_EXTRA_OECONF = "--with-tls"
diff --git a/meta/conf/machine/qemux86.conf b/meta/conf/machine/qemux86.conf
index 246d5a0c85..ad840c0498 100644
--- a/meta/conf/machine/qemux86.conf
+++ b/meta/conf/machine/qemux86.conf
@@ -6,7 +6,6 @@ PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
require conf/machine/include/tune-i586.inc
-require conf/machine/include/qemu.inc
MACHINE_FEATURES += "x86"
@@ -23,6 +22,8 @@ XSERVER ?= "xserver-xorg \
xf86-video-vmware \
qemugl"
+require conf/machine/include/qemu.inc
+
GLIBC_ADDONS = "nptl"
GLIBC_EXTRA_OECONF = "--with-tls"