aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-12-08 01:08:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-31 10:17:45 +0000
commitbbfa5c57ee97a96acf0b280ce342a515744b89a2 (patch)
tree05608deccf66b7e1037f9c03b5622d42051ba229
parent0c18fdd44accbcc04731e1e3f1ce1faa5e350db9 (diff)
downloadopenembedded-core-contrib-bbfa5c57ee97a96acf0b280ce342a515744b89a2.tar.gz
apr: avoid absolute paths for grep
The apr provides usr/share/build-1/libtool which is required by the recipe such as apache2, and it will find grep on the host and set absolute paths in libtool: GREP="/usr/bin/grep" If we build apr/apr-native on a host that grep is in "/usr/bin/grep", and re-use the sstate on another host with "/bin/grep", it will fail when build apache2/apache2-native with: | tmp/sysroots/x86_64-linux/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory | tmp/sysroots/intel-x86-64/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory (From OE-Core rev: 475709fc4f32e1ed01f45ee44819cd24e739eb43) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-support/apr/apr_1.5.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.5.1.bb b/meta/recipes-support/apr/apr_1.5.1.bb
index 49a08b0261..a27b2338d1 100644
--- a/meta/recipes-support/apr/apr_1.5.1.bb
+++ b/meta/recipes-support/apr/apr_1.5.1.bb
@@ -32,6 +32,11 @@ CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
do_configure_prepend() {
+ # Avoid absolute paths for grep since it causes failures
+ # when using sstate between different hosts with different
+ # install paths for grep.
+ export GREP="grep"
+
cd ${S}
./buildconf
}