aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Lund <malu@gomspace.com>2018-04-26 11:47:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 09:54:59 +0100
commit612d0468e34ca922b42a1176ab1e2feef72a2a13 (patch)
treed70f5257eaeb33c155a82c8a79efd6a78cde2b8f
parent0d8f68fe43b4da1a0d356fe6bedb52b8f2a02081 (diff)
downloadopenembedded-core-contrib-612d0468e34ca922b42a1176ab1e2feef72a2a13.tar.gz
mtd-utils: Add mtd-utils-tests package
Add mtd-utils-tests package which includes the test suites mtd-tests, ubi-tests, fs-tests, etc. These test suites are useful for verifying flash features or stress testing. Signed-off-by: Martin Lund <malu@gomspace.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/mtd/mtd-utils_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/mtd/mtd-utils_git.bb b/meta/recipes-devtools/mtd/mtd-utils_git.bb
index f50a42cf0e..a0e1cf76f6 100644
--- a/meta/recipes-devtools/mtd/mtd-utils_git.bb
+++ b/meta/recipes-devtools/mtd/mtd-utils_git.bb
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
inherit autotools pkgconfig update-alternatives
DEPENDS = "zlib lzo e2fsprogs util-linux"
+RDEPENDS_mtd-utils-tests += "bash"
PV = "2.0.1+${SRCPV}"
@@ -18,6 +19,8 @@ SRC_URI = "git://git.infradead.org/mtd-utils.git \
S = "${WORKDIR}/git/"
+EXTRA_OECONF += "--enable-install-tests"
+
# xattr support creates an additional compile-time dependency on acl because
# the sys/acl.h header is needed. libacl is not needed and thus enabling xattr
# regardless whether acl is enabled or disabled in the distro should be okay.
@@ -54,11 +57,12 @@ do_install () {
oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
}
-PACKAGES =+ "mtd-utils-jffs2 mtd-utils-ubifs mtd-utils-misc"
+PACKAGES =+ "mtd-utils-jffs2 mtd-utils-ubifs mtd-utils-misc mtd-utils-tests"
FILES_mtd-utils-jffs2 = "${sbindir}/mkfs.jffs2 ${sbindir}/jffs2dump ${sbindir}/jffs2reader ${sbindir}/sumtool"
FILES_mtd-utils-ubifs = "${sbindir}/mkfs.ubifs ${sbindir}/ubi*"
FILES_mtd-utils-misc = "${sbindir}/nftl* ${sbindir}/ftl* ${sbindir}/rfd* ${sbindir}/doc* ${sbindir}/serve_image ${sbindir}/recv_image"
+FILES_mtd-utils-tests = "${libexecdir}/mtd-utils/*"
BBCLASSEXTEND = "native nativesdk"