aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2018-03-20 15:36:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-11 07:49:31 +0100
commit20f2670e755bcbf90b2b6c08192c022fe7e7eaad (patch)
tree2c6a535e05a2633820fae752fe6c78b837aafc05
parent500e28311248713d4772480b81b10777390da909 (diff)
downloadopenembedded-core-contrib-20f2670e755bcbf90b2b6c08192c022fe7e7eaad.tar.gz
libical-dev_2.0: improve reproducibility
Remove build host references from distributed files. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/libical/libical_2.0.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-support/libical/libical_2.0.0.bb b/meta/recipes-support/libical/libical_2.0.0.bb
index dcc21cc16e..daa47abcbc 100644
--- a/meta/recipes-support/libical/libical_2.0.0.bb
+++ b/meta/recipes-support/libical/libical_2.0.0.bb
@@ -17,3 +17,10 @@ SRC_URI[sha256sum] = "654c11f759c19237be39f6ad401d917e5a05f36f1736385ed958e60cf2
UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
inherit cmake pkgconfig
+
+do_install_append_class-target () {
+ # Remove build host references
+ sed -i \
+ -e 's,${STAGING_LIBDIR},${libdir},g' \
+ ${D}${libdir}/cmake/LibIcal/LibIcalTargets-noconfig.cmake
+}