aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-03 15:09:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-03 10:24:22 +0100
commit8cfba07e24dae3d1837ccb5cb04e11f362519b0a (patch)
tree50a3a62ae6907032ce196b561d364427cdca9335
parentc8f9527f18e5dd813c0330ba409875d34c36f6ab (diff)
downloadopenembedded-core-contrib-8cfba07e24dae3d1837ccb5cb04e11f362519b0a.tar.gz
keymaps: mask keymap when necessary
When 'sysvinit' and 'systemd' are both in DISTRO_FEATURES, we need to prevent the init script from running via systemd. This is because that the functionality of the init script has implemented in systemd internally. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/keymaps/keymaps_1.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-bsp/keymaps/keymaps_1.0.bb b/meta/recipes-bsp/keymaps/keymaps_1.0.bb
index a3f2d89b26..925161b5d2 100644
--- a/meta/recipes-bsp/keymaps/keymaps_1.0.bb
+++ b/meta/recipes-bsp/keymaps/keymaps_1.0.bb
@@ -35,4 +35,14 @@ do_install () {
fi
}
+DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd-systemctl-native','',d)}"
+pkg_postinst_${PN} () {
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd sysvinit','true','false',d)}; then
+ if [ -n "$D" ]; then
+ OPTS="--root=$D"
+ fi
+ systemctl $OPTS mask keymap.service
+ fi
+}
+
ALLOW_EMPTY_${PN} = "1"