aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-10-07 17:06:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-18 15:47:13 +0100
commit675b48d12325ca791797cd26fd0d1aae50003da6 (patch)
treeed3bdf70ad231b3efc1043430053e9fc54090201
parentdd6a45536043af34c05a699e468cef4845f7affd (diff)
downloadopenembedded-core-contrib-675b48d12325ca791797cd26fd0d1aae50003da6.tar.gz
check: add check recipe for kbd to use for creating unit tests
enable ptest support for check itself Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-support/check/check_0.9.10.bb20
-rw-r--r--meta/recipes-support/check/files/ptest.patch29
-rw-r--r--meta/recipes-support/check/files/run-ptest3
3 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-support/check/check_0.9.10.bb b/meta/recipes-support/check/check_0.9.10.bb
new file mode 100644
index 0000000000..78eec145e9
--- /dev/null
+++ b/meta/recipes-support/check/check_0.9.10.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/check"
+SECTION = "libs"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
+ file://run-ptest \
+ file://ptest.patch \
+ "
+
+SRC_URI[md5sum] = "6d10a8efb9a683467b92b3bce97aeb30"
+SRC_URI[sha256sum] = "823819235753e94ae0bcab3c46cc209de166c32ff2f52cefe120597db4403e6d"
+
+inherit autotools ptest
+
+RDEPENDS_${PN} = "make"
+
+BBCLASSEXTEND = "native"
diff --git a/meta/recipes-support/check/files/ptest.patch b/meta/recipes-support/check/files/ptest.patch
new file mode 100644
index 0000000000..3cb2b25e05
--- /dev/null
+++ b/meta/recipes-support/check/files/ptest.patch
@@ -0,0 +1,29 @@
+Index: check-0.9.10/Makefile.am
+===================================================================
+--- check-0.9.10.orig/Makefile.am
++++ check-0.9.10/Makefile.am
+@@ -45,6 +45,9 @@ ACLOCAL_AMFLAGS = -I m4
+ doc/check_html:
+ $(MAKE) -C doc check_html
+
++install-ptest:
++ $(MAKE) -C tests install-ptest
++
+ # check we can do a clean build, including docs.
+ # perhaps we should check for out of date (svn st -u) and modified files.
+ prereleasecheck: doc/check_html
+Index: check-0.9.10/tests/Makefile.am
+===================================================================
+--- check-0.9.10.orig/tests/Makefile.am
++++ check-0.9.10/tests/Makefile.am
+@@ -81,3 +81,10 @@ ex_xml_output_LDADD = $(top_builddir)/sr
+ AM_CPPFLAGS = -I$(top_builddir)/src -I$(top_srcdir)/src
+
+ CLEANFILES = *~ *.log *.xml test_logfile
++
++install-ptest:
++ @$(MKDIR_P) $(DESTDIR)/tests
++ @for file in $(noinst_PROGRAMS) $(EXTRA_DIST); do \
++ install -m 0755 $$file $(DESTDIR)/tests; \
++ done;
++ @sed -e 's/^Makefile/_Makefile/' < Makefile > $(DESTDIR)/Makefile
diff --git a/meta/recipes-support/check/files/run-ptest b/meta/recipes-support/check/files/run-ptest
new file mode 100644
index 0000000000..d4969ef4d1
--- /dev/null
+++ b/meta/recipes-support/check/files/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+make -k check-TESTS
+