summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-01-10 17:24:21 +0000
committerArmin Kuster <akuster808@gmail.com>2020-02-23 09:34:04 -0800
commit4ee9c60797e95674ae138245b3a4de063b2e95db (patch)
tree998791dbad0997cf4eb1cb2b4ebe9b29ba41c1e3
parent559fd361440898479937c887a0e4f8cfb8c46891 (diff)
downloadopenembedded-core-contrib-4ee9c60797e95674ae138245b3a4de063b2e95db.tar.gz
perl: improve reproducibility
Occasionally the reproducibility selftest fails because perl-pod differs, specifically that the perltoc.pod file was sometimes missing modules. Debugging revealed that there are missing dependencies so there is a build race: building perltoc.pod from an clean build tree results in no modules being listed at all. A bug has been filed at https://github.com/arsv/perl-cross/issues/86 to solve this properly, but for now we can just delete perltoc.pod after make has finished and re-generate it. [ YOCTO #13726 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 7e0f6c9ea4f824f29dc30c6631fd8039ebe83a0b) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.1.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.30.1.bb b/meta/recipes-devtools/perl/perl_5.30.1.bb
index c68ffb1376..15bc5a43fe 100644
--- a/meta/recipes-devtools/perl/perl_5.30.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.30.1.bb
@@ -112,6 +112,14 @@ print(datetime.fromtimestamp($SOURCE_DATE_EPOCH, timezone.utc).strftime('%a %b %
do_compile() {
oe_runmake
+ # This isn't generated reliably so delete and re-generate.
+ # https://github.com/arsv/perl-cross/issues/86
+
+ if [ -e pod/perltoc.pod ]; then
+ bbnote Rebuilding perltoc.pod
+ rm -f pod/perltoc.pod
+ oe_runmake pod/perltoc.pod
+ fi
}
do_install() {