summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonrad Weihmann <kweihmann@outlook.com>2021-09-21 15:53:44 +0200
committerAnuj Mittal <anuj.mittal@intel.com>2021-09-29 16:22:10 +0800
commit75cdae00b80e0a64bb02f274cdf8b9a321bd57e5 (patch)
tree8c9ac66b4298af7968a4b5e382c9408cc29a843b
parentf0789ed2f4b49f8c63dedd770e5c78bac6cae456 (diff)
downloadopenembedded-core-contrib-75cdae00b80e0a64bb02f274cdf8b9a321bd57e5.tar.gz
expat: pull from github releases
sometimes we can find release tarballs from sourceforge are not fully distributed along all download mirrors leading to fetching failures, depending on what download mirror will be chosen by sourceforge servers. As the project moved to github anyway, it's better to pull the tarballs directly from github releases - serving the very same static artifacts. Add an override UPSTREAM_CHECK_URI to enable devtool upgrade checks Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> (backported from commit 2a1743ace5aa41b188f77853d0f00c9e5a359c6d) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-core/expat/expat_2.2.10.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/expat/expat_2.2.10.bb b/meta/recipes-core/expat/expat_2.2.10.bb
index a54d832e52..08e8ff1cea 100644
--- a/meta/recipes-core/expat/expat_2.2.10.bb
+++ b/meta/recipes-core/expat/expat_2.2.10.bb
@@ -6,12 +6,16 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
-SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
+VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
+
+SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
file://libtool-tag.patch \
file://run-ptest \
file://0001-Add-output-of-tests-result.patch \
"
+UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
+
SRC_URI[sha256sum] = "b2c160f1b60e92da69de8e12333096aeb0c3bf692d41c60794de278af72135a5"
EXTRA_OECMAKE_class-native += "-DEXPAT_BUILD_DOCS=OFF"