summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHaris Okanovic <haris.okanovic@ni.com>2019-11-07 16:06:51 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-10 14:04:55 +0000
commite935cba0122a93df611c9a846c16b7841b715fd8 (patch)
tree54eb1bd3b681a0ff942b930d49ecc80fb3277b24
parentc0d663da05c5a2c466658246feaa7872756ded2c (diff)
downloadopenembedded-core-contrib-e935cba0122a93df611c9a846c16b7841b715fd8.tar.gz
gnupg/libksba/npth/pinentry: Add nativesdk to BBCLASSEXTEND
Enable nativesdk builds of gnupg and it's dependencies (libksba, npth, and pinentry) to fix builds of nativesdk-opkg. This is necessary on distribution which enable gpg signature verification in opkg and also build SDK images that include opkg. Signed-off-by: Haris Okanovic <haris.okanovic@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.17.bb2
-rw-r--r--meta/recipes-support/libksba/libksba_1.3.5.bb2
-rw-r--r--meta/recipes-support/npth/npth_1.6.bb2
-rw-r--r--meta/recipes-support/pinentry/pinentry_1.1.0.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.17.bb b/meta/recipes-support/gnupg/gnupg_2.2.17.bb
index ab19a1ad11..bb8885f1c8 100644
--- a/meta/recipes-support/gnupg/gnupg_2.2.17.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.2.17.bb
@@ -70,4 +70,4 @@ PACKAGECONFIG ??= "gnutls"
PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/libksba/libksba_1.3.5.bb b/meta/recipes-support/libksba/libksba_1.3.5.bb
index 4deda1843f..336d7f8177 100644
--- a/meta/recipes-support/libksba/libksba_1.3.5.bb
+++ b/meta/recipes-support/libksba/libksba_1.3.5.bb
@@ -27,4 +27,4 @@ do_configure_prepend () {
rm -f ${S}/m4/gpg-error.m4
}
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/npth/npth_1.6.bb b/meta/recipes-support/npth/npth_1.6.bb
index 8310efb106..233e0dc4a4 100644
--- a/meta/recipes-support/npth/npth_1.6.bb
+++ b/meta/recipes-support/npth/npth_1.6.bb
@@ -24,4 +24,4 @@ do_install_append() {
oe_multilib_header npth.h
}
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/pinentry/pinentry_1.1.0.bb b/meta/recipes-support/pinentry/pinentry_1.1.0.bb
index fb529d25d6..8c500dcadc 100644
--- a/meta/recipes-support/pinentry/pinentry_1.1.0.bb
+++ b/meta/recipes-support/pinentry/pinentry_1.1.0.bb
@@ -35,4 +35,4 @@ EXTRA_OECONF = " \
--disable-rpath \
"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"