summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhixiong Chi <zhixiong.chi@windriver.com>2019-11-06 19:30:29 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-10 14:04:55 +0000
commit674596421320de08142e010fdd65ec6f0a0f34e9 (patch)
tree9de7075f7abc91214db59eebbefbf8f89961aef8
parent854a9aa2212cc24620c9ad3d24acc52f686b5c1a (diff)
downloadopenembedded-core-contrib-674596421320de08142e010fdd65ec6f0a0f34e9.tar.gz
libtirpc: create the symbol link for rpc header files
Since the Sun RPC is deprecated in glibc, the rpc header files are not provided any more, but it allows alternative RPC implementations, such as TIRPC or rpcsvc-proto, to be used. So we create the symbol link for rpc header files for tirpc to be more compatible with the glibc version and the application usage. Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_1.1.4.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.1.4.bb b/meta/recipes-extended/libtirpc/libtirpc_1.1.4.bb
index e73ffe7b17..633cececd4 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.1.4.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.1.4.bb
@@ -23,6 +23,20 @@ EXTRA_OECONF = "--disable-gssapi"
do_install_append() {
chown root:root ${D}${sysconfdir}/netconfig
+ install -d ${D}${includedir}/rpc
+ install -d ${D}${includedir}/rpcsvc
+ for link_header in ${D}${includedir}/tirpc/rpc/*; do
+ if [ -f $link_header -a ! -e ${D}/${includedir}/rpc/$(basename $link_header) ]; then
+ ln -sf ../tirpc/rpc/$(basename $link_header) ${D}${includedir}/rpc/$(basename $link_header)
+ fi
+ done
+ for link_header in ${D}${includedir}/tirpc/rpcsvc/*; do
+ if [ -f $link_header -a ! -e ${D}/${includedir}/rpcsvc/$(basename $link_header) ]; then
+ ln -sf ../tirpc/rpc/$(basename $link_header) ${D}${includedir}/rpcsvc/$(basename $link_header)
+ fi
+ done
+ ln -sf tirpc/netconfig.h ${D}/${includedir}/netconfig.h
+
}
BBCLASSEXTEND = "native nativesdk"