summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-11-13 15:24:00 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-14 12:55:57 +0000
commitb0293d9734372c90a0b4eec7967b55e0db96102e (patch)
tree8c9333bad32aa8b4ee31b1c9b55d721d8a7fbaff
parent3cc887a72c5726024c3699e6a3deb72fad4992a9 (diff)
downloadopenembedded-core-contrib-b0293d9734372c90a0b4eec7967b55e0db96102e.tar.gz
icecc-create-env: Use OE patchelf in SDK
The Icecream environment creation script runs when the SDK is installed and uses patchelf to fix up executables. Rather than rely on the host system to provided patchelf (which often can be older versions that produce buggy executables), mark the OE version of patchelf as a dependency of icecc-create-env when included in the SDK. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb b/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
index 053945ebbc..231c1c20ec 100644
--- a/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
+++ b/meta/recipes-devtools/icecc-create-env/icecc-create-env_0.1.bb
@@ -34,3 +34,5 @@ do_install() {
}
BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN}_class-nativesdk = "patchelf"