summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-07 15:36:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-10 14:04:55 +0000
commitd10e8384bfa08d928dfec3a00c59006badfc88ee (patch)
tree66f9ef6825404ae5bacd4b167093d8ce8582953e
parent0fb92b500b7d6b84368ca3a85e675400c6473987 (diff)
downloadopenembedded-core-contrib-d10e8384bfa08d928dfec3a00c59006badfc88ee.tar.gz
libevent: update packaging (one package per shared library)
libevent produces several libraries that might or might not be used in the end. We can prevent those potentially unused libraries from being pulled into a file-system by splitting the individual shared libraries into individual packages. Because this recipe only provides shared libraries which are handled automatically by bitbake (shlibs), there is no need to add the subpackages to the RDEPENDS of PN for backwards compatibility. The packaging process of dependees will simply pull in the sub-packages as runtime dependency as needed. This also how Debian splits this up. While updating the packaging, we can also drop event_rpcgen.py which appears to be a tool for generating rpc bindings, i.e. something that should normally be in -dev. Given Debian doesn't package this at all, and given it actually requires python to run but no runtime dependency is stated at the moment, it would appear that no users of this exist. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.11.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.11.bb b/meta/recipes-support/libevent/libevent_2.1.11.bb
index f005ab8bda..8c7c49e7dd 100644
--- a/meta/recipes-support/libevent/libevent_2.1.11.bb
+++ b/meta/recipes-support/libevent/libevent_2.1.11.bb
@@ -31,9 +31,17 @@ inherit ptest multilib_header
DEPENDS = "zlib"
+PACKAGES_DYNAMIC = "^${PN}-.*$"
+python split_libevent_libs () {
+ do_split_packages(d, '${libdir}', r'^libevent_([a-z]*)-.*\.so\..*', '${PN}-%s', '${SUMMARY} (%s)', prepend=True, allow_links=True)
+}
+PACKAGESPLITFUNCS_prepend = "split_libevent_libs "
+
BBCLASSEXTEND = "native nativesdk"
do_install_append() {
+ rm ${D}${bindir}/event_rpcgen.py
+ rmdir ${D}${bindir}
oe_multilib_header event2/event-config.h
}