aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-09 09:48:44 +0000
committerArmin Kuster <akuster808@gmail.com>2017-04-01 08:41:18 -0400
commit4b6cf8184c713304e1c5d46957b39c4be9e4d48e (patch)
tree7058fbe2cb1ff930828b38ce148797dc8c76d40a
parentcadf90dc872d75cd12f8536f3deda5aba01bc7e8 (diff)
downloadopenembedded-core-contrib-4b6cf8184c713304e1c5d46957b39c4be9e4d48e.tar.gz
tzcode-native: Set cc to ${CC}
Building on a system without "cc" showed this recipe doesn't respect the $CC variable. Fix this by passing the right option to the makefile. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 402080c0a77443f541fa3d658b79f3fba327279d)
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2017a.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2017a.bb b/meta/recipes-extended/tzcode/tzcode-native_2017a.bb
index 0daac531fd..2c26744f33 100644
--- a/meta/recipes-extended/tzcode/tzcode-native_2017a.bb
+++ b/meta/recipes-extended/tzcode/tzcode-native_2017a.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}"
inherit native
+EXTRA_OEMAKE += "cc=${CC}"
+
do_install () {
install -d ${D}${bindir}/
install -m 755 zic ${D}${bindir}/