summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2019-11-21 10:58:24 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-25 22:03:43 +0000
commitb79a2cec587a1f9f3d6a6f979f5c5504baccd75f (patch)
tree1641bbc4606d5bfb253aa7c970dec02981943198
parenteab7f448aa537539b45ee21df4ea25de97e60a7e (diff)
downloadopenembedded-core-contrib-b79a2cec587a1f9f3d6a6f979f5c5504baccd75f.tar.gz
librsvg: Fix build reproducibility
librsvg was encoding the path to the build directory in order to find a font file for testing. This wouldn't work in OE anyway since the build directory isn't present at that exact location on the target, so remove the offending path to make the build reproducible. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-gnome/librsvg/librsvg/0001-Remove-non-reproducible-SRCDIR.patch30
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.40.20.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg/0001-Remove-non-reproducible-SRCDIR.patch b/meta/recipes-gnome/librsvg/librsvg/0001-Remove-non-reproducible-SRCDIR.patch
new file mode 100644
index 0000000000..75fc7f9d0b
--- /dev/null
+++ b/meta/recipes-gnome/librsvg/librsvg/0001-Remove-non-reproducible-SRCDIR.patch
@@ -0,0 +1,30 @@
+From bea5156cd7e7122715b26c769c35928141a1da2c Mon Sep 17 00:00:00 2001
+From: Joshua Watt <JPEWhacker@gmail.com>
+Date: Mon, 18 Nov 2019 14:46:34 -0600
+Subject: [PATCH] Remove non-reproducible SRCDIR
+
+Removes SRCDIR as the prefix for finding the test font. This wouldn't
+work anyway, since that path is not present on the target.
+
+This patch is specific to OE, since it appears that this entire method
+of testing was removed when upstream was re-written in rust
+
+Upstream-Status: Inappropriate [OE-specific, no longer present upstream]
+Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
+---
+ rsvg-cairo-draw.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rsvg-cairo-draw.c b/rsvg-cairo-draw.c
+index caa9104..cfb7ed2 100644
+--- a/rsvg-cairo-draw.c
++++ b/rsvg-cairo-draw.c
+@@ -398,7 +398,7 @@ set_font_options_for_testing (PangoContext *context)
+ static void
+ create_font_config_for_testing (RsvgCairoRender *render)
+ {
+- const char *font_path = SRCDIR "/tests/resources/LiberationSans-Regular.ttf";
++ const char *font_path = "/tests/resources/LiberationSans-Regular.ttf";
+
+ if (render->font_config_for_testing != NULL)
+ return;
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.40.20.bb b/meta/recipes-gnome/librsvg/librsvg_2.40.20.bb
index 7f98127fd0..6dd0533a5d 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.40.20.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.40.20.bb
@@ -20,6 +20,7 @@ inherit gnomebase gtk-doc pixbufcache upstream-version-is-even gobject-introspec
SRC_URI += "file://gtk-option.patch \
file://0001-Auto-detect-Bsymbolic-fixes-configure-on-macOS.patch \
+ file://0001-Remove-non-reproducible-SRCDIR.patch \
"
SRC_URI[archive.md5sum] = "4949d313b0c5d9161a5c259104af5568"