aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-12-26 17:59:04 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-27 22:50:00 +0000
commit74d3b4a199bfeae99dfbe6f23f1c3cb4bf76abff (patch)
tree6539feea8ec2df1bc990540cada31b6f87f67e83
parentda527d73f5eeae0f29b5f99aab757491d3f87ec7 (diff)
downloadopenembedded-core-contrib-74d3b4a199bfeae99dfbe6f23f1c3cb4bf76abff.tar.gz
opkg: upgrade to version 0.4.0
- Drop 0001-remove_maintainer_scripts-use-strict-matching.patch Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch56
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.0.bb (renamed from meta/recipes-devtools/opkg/opkg_0.3.6.bb)5
2 files changed, 2 insertions, 59 deletions
diff --git a/meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch b/meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch
deleted file mode 100644
index ec160290be..0000000000
--- a/meta/recipes-devtools/opkg/opkg/0001-remove_maintainer_scripts-use-strict-matching.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 55c4ad666e76281bdd0db55fa6f4ab2744fea7e4 Mon Sep 17 00:00:00 2001
-From: Alejandro del Castillo <alejandro.delcastillo@ni.com>
-Date: Tue, 4 Sep 2018 18:06:00 -0500
-Subject: [PATCH] remove_maintainer_scripts: use strict matching
-
-The function is using a glob to select which metadata files needs to be
-deleted during package removal, on the info_dir. However, the glob may
-match metadata files from packages with similar names. For example,
-during removal of package glibc-binary-localedata-de-at, the current
-logic was also removing the metadata for
-glibc-binary-localedata-de-at.iso-8859-1. Add check for an exact match
-before deletion.
-
-Fixes bugzilla: 12905
-
-Upstream-Status: Submitted [https://groups.google.com/forum/#!topic/opkg-devel/Fr40Yt0NBno]
-Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
----
- libopkg/opkg_remove.c | 14 +++++++++++---
- 1 file changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/libopkg/opkg_remove.c b/libopkg/opkg_remove.c
-index 82125fa..3936628 100644
---- a/libopkg/opkg_remove.c
-+++ b/libopkg/opkg_remove.c
-@@ -137,7 +137,7 @@ void remove_maintainer_scripts(pkg_t * pkg)
- {
- unsigned int i;
- int err;
-- char *globpattern;
-+ char *globpattern, *filename, *lastdot;
- glob_t globbuf;
-
- if (opkg_config->noaction)
-@@ -151,8 +151,16 @@ void remove_maintainer_scripts(pkg_t * pkg)
- return;
-
- for (i = 0; i < globbuf.gl_pathc; i++) {
-- opkg_msg(INFO, "Deleting %s.\n", globbuf.gl_pathv[i]);
-- unlink(globbuf.gl_pathv[i]);
-+ filename = xstrdup(basename(globbuf.gl_pathv[i]));
-+ lastdot = strrchr(filename, '.');
-+ *lastdot = '\0';
-+ // Only delete files that match the package name (the glob may match files
-+ // with similar names)
-+ if (!strcmp(filename, pkg->name)) {
-+ opkg_msg(INFO, "Deleting %s.\n", globbuf.gl_pathv[i]);
-+ unlink(globbuf.gl_pathv[i]);
-+ }
-+ free(filename);
- }
- globfree(&globbuf);
- }
---
-2.18.0
-
diff --git a/meta/recipes-devtools/opkg/opkg_0.3.6.bb b/meta/recipes-devtools/opkg/opkg_0.4.0.bb
index 6ebd58b967..9b7cf3f596 100644
--- a/meta/recipes-devtools/opkg/opkg_0.3.6.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.4.0.bb
@@ -14,11 +14,10 @@ PE = "1"
SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
file://opkg.conf \
file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
- file://0001-remove_maintainer_scripts-use-strict-matching.patch \
"
-SRC_URI[md5sum] = "79e04307f6f54db431c251772d7d987c"
-SRC_URI[sha256sum] = "f607f0e61be8cf8a3bbd0d2dccd9ec9e9b6c21dd4307b671c600d6eeaf84d30b"
+SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5"
+SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe"
inherit autotools pkgconfig systemd