summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-04-05 22:20:59 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-11 15:26:25 +0100
commitbcc560134ebfbeeb0c1cc7b6c96e2da629df67a2 (patch)
tree11bf3b210a10b5b6a5079251ed336c0d67c56735
parentb6138d28f750f4306bc8b9c9baa047d9971dcb17 (diff)
downloadopenembedded-core-contrib-bcc560134ebfbeeb0c1cc7b6c96e2da629df67a2.tar.gz
gstreamer1.0-python: rework gobject-introspection handling
gobject-introspection is mandatory for gstreamer1.0-python - there is no configure option to enable or disable it. To handle properly, this patch does: * Make 'gobject-introspection-data' a required distro feature * Add 'UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"' - it was removed in gobject-introspection.bbclass to avoid | ERROR: libgee-0.18.0-r0 do_configure: QA Issue: libgee: configure was passed unrecognised options: --disable-schemas-install [unknown-configure-option] Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
index 8d45ca2668..048aaf4413 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
@@ -16,7 +16,11 @@ PNREAL = "gst-python"
S = "${WORKDIR}/${PNREAL}-${PV}"
-inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
+
+inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
do_install_append() {
# gstpythonplugin hardcodes the location of the libpython from the build