summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-03-02 14:14:26 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-03 13:06:23 +0000
commit6f31da5632220a09ac65b8f361cdc9c64e64ce35 (patch)
tree43bc849c1888d67bc6baf095cf8cb6f817fbcc52
parent136314ffd107654b7673d937acafb7f4a81ac5a9 (diff)
downloadopenembedded-core-contrib-6f31da5632220a09ac65b8f361cdc9c64e64ce35.tar.gz
psplash: update to latest git revision and clean up
Update SRCREV to pick up: c359546 Fix psplash-systemd failures 3c0a4f3 Remove generated psplash-poky-img.h Also: * set the unit type in psplash-start.service to "notify" to complete the psplash-systemd race fix * remove the rest of the now unnecessary has_png logic bits * change the generated image header destination to B instead of S since that now works after the recent makefile changes, and will avoid unnecessarily polluting the source tree Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/psplash/files/psplash-start.service1
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb7
2 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-core/psplash/files/psplash-start.service b/meta/recipes-core/psplash/files/psplash-start.service
index af9d5d6c20..a8c97c7a75 100644
--- a/meta/recipes-core/psplash/files/psplash-start.service
+++ b/meta/recipes-core/psplash/files/psplash-start.service
@@ -4,6 +4,7 @@ DefaultDependencies=no
RequiresMountsFor=/run
[Service]
+Type=notify
ExecStart=/usr/bin/psplash
[Install]
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 875adb13fc..22c71f099b 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=8f232c1e95929eacab37f00900580224"
DEPENDS = "gdk-pixbuf-native"
-SRCREV = "aea172a24c5b0bdc0f4efa780c0faa00c9238362"
+SRCREV = "0a902f7cd875ccf018456451be369f05fa55f962"
PV = "0.1+git${SRCPV}"
PR = "r15"
@@ -24,7 +24,6 @@ python __anonymous() {
splashfiles = d.getVar('SPLASH_IMAGES').split()
pkgs = []
localpaths = []
- haspng = False
for uri in splashfiles:
fetcher = bb.fetch2.Fetch([uri], d)
flocal = os.path.basename(fetcher.localpath(uri))
@@ -42,8 +41,6 @@ python __anonymous() {
bb.fatal("The output name '%s' derived from the URI %s is not valid, please specify the outsuffix parameter" % (outname, uri))
else:
pkgs.append(outname)
- if flocal.endswith(".png"):
- haspng = True
localpaths.append(flocal)
# Set these so that we have less work to do in do_compile and do_install_append
@@ -82,7 +79,7 @@ python do_compile () {
# Build a separate executable for each splash image
workdir = d.getVar('WORKDIR')
convertscript = "%s/make-image-header.sh" % d.getVar('S')
- destfile = "%s/psplash-poky-img.h" % d.getVar('S')
+ destfile = "%s/psplash-poky-img.h" % d.getVar('B')
localfiles = d.getVar('SPLASH_LOCALPATHS').split()
outputfiles = d.getVar('SPLASH_INSTALL').split()
for localfile, outputfile in zip(localfiles, outputfiles):