summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-09-22 16:25:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-22 21:37:56 +0100
commit35bec42c4023a00a0a3639935633051ce9c1c0ba (patch)
tree4838594dca60fc47cba0e01cc9c48770e9f3ad39
parentbac2c95f6331deafd3e07c927ba00a202db9a12b (diff)
downloadopenembedded-core-contrib-35bec42c4023a00a0a3639935633051ce9c1c0ba.tar.gz
binutils: handle symlink files for gprofng
It provides gprofng by binutils 2.39 for x86, x86_64 and aarch64 according to configure.ac: https://sourceware.org/git/?p=binutils-gdb.git;a=blob;f=configure.ac;h=a5555a9c91b42214afc46a0ab8b629e4c6fedcc0;hb=HEAD#l401 Add them to USE_ALTERNATIVES_FOR the same as others to handle symlink files via update-alternative mechanism. And it disables gprofng for clang and musl in .bb file, so clear GPROFNG_ALTS for them too. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/binutils/binutils.inc18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/binutils/binutils.inc b/meta/recipes-devtools/binutils/binutils.inc
index 789c8bec21..4dde387a8a 100644
--- a/meta/recipes-devtools/binutils/binutils.inc
+++ b/meta/recipes-devtools/binutils/binutils.inc
@@ -36,6 +36,23 @@ FILES:${PN}-dev = " \
# Rather than duplicating multiple entries for these, make one
# list and reuse it.
+GPROFNGS = " \
+ gp-archive \
+ gp-collect-app \
+ gp-display-html \
+ gp-display-src \
+ gp-display-text \
+ gprofng \
+"
+GPROFNG_ALTS ?= ""
+GPROFNG_ALTS:x86 = "${GPROFNGS}"
+GPROFNG_ALTS:x86-64 = "${GPROFNGS}"
+GPROFNG_ALTS:aarch64 = "${GPROFNGS}"
+
+# it disables gprofng for clang and musl in the bb file
+GPROFNG_ALTS:toolchain-clang = ""
+GPROFNG_ALTS:libc-musl = ""
+
LDGOLD_ALTS ?= "ld.gold dwp"
LDGOLD_ALTS:riscv64 = ""
LDGOLD_ALTS:riscv32 = ""
@@ -48,6 +65,7 @@ USE_ALTERNATIVES_FOR = " \
c++filt \
elfedit \
gprof \
+ ${GPROFNG_ALTS} \
ld \
ld.bfd \
${LDGOLD_ALTS} \