summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-09-26 12:15:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-26 22:04:32 +0100
commit061b9cf35a63b38a34356580395c5694579cbb98 (patch)
treee4aa8c3d01766c32a7fa07c44ae081bcf38bc404
parent68b07bb7f0f01925f9da1cb966239ee49d5c84e3 (diff)
downloadopenembedded-core-contrib-061b9cf35a63b38a34356580395c5694579cbb98.tar.gz
dnf: add dummy packages for testing
oeqa/runtime needs packages which are always built, but we don't want to use packages which have large side effects (unlike the current test recipe, run-postinsts). As finding a package that is both of these things isn't easy, for now dnf can generate its own. Moving forward this should be generalised and all of the package manager tests unified. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/dnf/dnf_4.14.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.14.0.bb b/meta/recipes-devtools/dnf/dnf_4.14.0.bb
index 48f7e28418..62df8c4ace 100644
--- a/meta/recipes-devtools/dnf/dnf_4.14.0.bb
+++ b/meta/recipes-devtools/dnf/dnf_4.14.0.bb
@@ -88,3 +88,9 @@ SYSTEMD_SERVICE:${PN} = "dnf-makecache.service dnf-makecache.timer \
SYSTEMD_AUTO_ENABLE ?= "disable"
SKIP_RECIPE[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
+
+# Packages for testing purposes
+PACKAGES += "${PN}-test-main ${PN}-test-dep"
+ALLOW_EMPTY:${PN}-test-main = "1"
+ALLOW_EMPTY:${PN}-test-dep = "1"
+RRECOMMENDS:${PN}-test-main = "${PN}-test-dep"