aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJian Liu <jian.liu@windriver.com>2015-02-26 10:35:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-05 17:47:09 +0000
commit9383f635858e35e8fb83fba1750a8c6e4b4274b1 (patch)
treea6505ed11d6645d830f6064f4bece81e038a1ad6
parent3c78468f12296abd02abce6eeac0f69bc7509958 (diff)
downloadopenembedded-core-contrib-9383f635858e35e8fb83fba1750a8c6e4b4274b1.tar.gz
man: fix bugs of makewhatis script
- man-1.6e-whatis2.patch does not delete the tail "fi" fix it to avoid syntax error - Use the command "which" to get the path of awk Signed-off-by: Jian Liu <jian.liu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/man/man/man-1.6e-whatis2.patch7
-rw-r--r--meta/recipes-extended/man/man/man-1.6g-whatis3.patch20
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb4
3 files changed, 30 insertions, 1 deletions
diff --git a/meta/recipes-extended/man/man/man-1.6e-whatis2.patch b/meta/recipes-extended/man/man/man-1.6e-whatis2.patch
index 7f013836c0..fc4ed3135d 100644
--- a/meta/recipes-extended/man/man/man-1.6e-whatis2.patch
+++ b/meta/recipes-extended/man/man/man-1.6e-whatis2.patch
@@ -50,3 +50,10 @@ Index: man-1.6f/src/makewhatis.sh
here=`pwd`
cd $mandir
for i in $sections
+@@ -447,7 +447,6 @@
+
+ chmod 644 ${mandir1}/whatis
+ rm $TMPFILE
+- fi
+ done
+ done
diff --git a/meta/recipes-extended/man/man/man-1.6g-whatis3.patch b/meta/recipes-extended/man/man/man-1.6g-whatis3.patch
new file mode 100644
index 0000000000..6334456857
--- /dev/null
+++ b/meta/recipes-extended/man/man/man-1.6g-whatis3.patch
@@ -0,0 +1,20 @@
+Do not use absolute path for awk while getting the path of awk
+when running makewhatis.
+This can avoid errors if path of awk changes.
+
+Upstream-Status: Submitted [man-1.6g]
+
+Signed-off-by: Jian Liu <jian.liu@windriver.com>
+
+diff -Nur man-1.6g.orig/src/makewhatis.sh man-1.6g/src/makewhatis.sh
+--- man-1.6g.orig/src/makewhatis.sh 2015-02-25 16:13:12.657611419 +0800
++++ man-1.6g/src/makewhatis.sh 2015-02-25 16:14:49.334694815 +0800
+@@ -67,7 +67,7 @@
+ # but that leads to problems and bugs.
+
+ # AWK=/usr/bin/gawk
+-AWK=@awk@
++AWK=`which awk`
+
+ # Find a place for our temporary files. If security is not a concern, use
+ # TMPFILE=/tmp/whatis$$; TMPFILEDIR=none
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
index cd9edbed89..d4a4b26fc5 100644
--- a/meta/recipes-extended/man/man_1.6g.bb
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -50,7 +50,9 @@ SRC_URI = "http://pkgs.fedoraproject.org/lookaside/pkgs/man2html/${BP}.tar.gz/ba
file://man.1.gz;unpack=false \
file://man.7.gz;unpack=false \
file://man.conf \
- file://manpath.5.gz;unpack=false"
+ file://manpath.5.gz;unpack=false \
+ file://man-1.6g-whatis3.patch \
+"
SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"
SRC_URI[sha256sum] = "ccdcb8c3f4e0080923d7e818f0e4a202db26c46415eaef361387c20995b8959f"