aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-26 17:35:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-27 09:15:54 +0000
commit9188a2672013cb6960590f03f753178999fe4c3c (patch)
treedd34931aeffe911744f88086fc7aea285eaa019d
parent0df811d5afdb947bfef98f7c53268259c99b88be (diff)
downloadopenembedded-core-contrib-9188a2672013cb6960590f03f753178999fe4c3c.tar.gz
pciutils: add PACKAGECONFIG for 'hwdb'
Add PACKAGECONFIG for 'hwdb' to fix the following QA warning. WARNING: QA Issue: libpci rdepends on libudev, but it isn't a build dependency? [build-deps] WARNING: QA Issue: pciutils rdepends on libudev, but it isn't a build dependency? [build-deps] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/pciutils/pciutils_3.3.0.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-bsp/pciutils/pciutils_3.3.0.bb b/meta/recipes-bsp/pciutils/pciutils_3.3.0.bb
index 71f7e04d62..f544919e8e 100644
--- a/meta/recipes-bsp/pciutils/pciutils_3.3.0.bb
+++ b/meta/recipes-bsp/pciutils/pciutils_3.3.0.bb
@@ -18,13 +18,18 @@ SRC_URI[sha256sum] = "413395d4bdc66fdedd6c993ed9083d1dd73812bf2a679d320f73de35c7
inherit multilib_header
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[hwdb] = "HWDB=yes,HWDB=no,udev"
+
PCI_CONF_FLAG = "ZLIB=yes DNS=yes SHARED=yes"
# see configure.patch
do_configure () {
(
cd lib && \
- ${PCI_CONF_FLAG} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
+ # EXTRA_OECONF for this recipe could only possibly contain 'HWDB=yes/no', so we put it
+ # before ./configure
+ ${PCI_CONF_FLAG} ${EXTRA_OECONF} ./configure ${PV} ${datadir} ${TARGET_OS} ${TARGET_ARCH}
)
}