aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Eliaser <max.eliaser@intel.com>2014-07-29 11:07:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-02 09:21:14 +0100
commit39cf9bcc28df7a4a37bc32e220ddc57b645350d4 (patch)
tree9e08619fb3d870bd4567c8522eaa3d69276e931c
parent92f956d813303f8ee86fd40a4ee3d604a9b4e76e (diff)
downloadopenembedded-core-contrib-39cf9bcc28df7a4a37bc32e220ddc57b645350d4.tar.gz
python: python-pycairo: add python-pycairo-native
A -native variant of python-pycairo will be necessary for running the native version of pybootchartgui. It may also come in handy for running other Python utilities from the native sysroot. Signed-off-by: Max Eliaser <max.eliaser@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-pycairo_1.10.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycairo_1.10.0.bb b/meta/recipes-devtools/python/python-pycairo_1.10.0.bb
index 5b59b6ccc1..70fe25c1a1 100644
--- a/meta/recipes-devtools/python/python-pycairo_1.10.0.bb
+++ b/meta/recipes-devtools/python/python-pycairo_1.10.0.bb
@@ -20,6 +20,8 @@ S = "${WORKDIR}/py2cairo-${PV}"
inherit distutils pkgconfig
+BBCLASSEXTEND = "native"
+
do_configure() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} ./waf configure --prefix=${D}${prefix} --libdir=${D}${libdir}
}