aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-11-06 00:33:38 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-09 10:17:04 +0000
commit82ac2a29126dc38d23c278b82d129d73b17000b7 (patch)
treedbaa710d9b74be1d0b508fc79e42fc5faf99f31d
parent40dd71a4e0beade84ecd686559243a10e55c3a2d (diff)
downloadopenembedded-core-contrib-82ac2a29126dc38d23c278b82d129d73b17000b7.tar.gz
perl: set the perl libraries search path
The default value for this is ../../lib which ends up with something like: | ./sysroots/x86_64-linux/usr/bin/perl-native/perl5.20.0.real \ | "-I../../lib" "-I../../lib" "-MExtUtils::Command::MM" -e pod2man \ | "--" --section=0 --perm_rw=644 perldoc.pod blib/man1/perldoc.1 in this case, nativeperl will find libraries from the target build, When using an x86-64 host to target Haswell, you can end up with ../../lib including precompiled modules which use Haswell instructions, it fails with: | Running pm_to_blib for dist/if directly | Skip ../../lib/if.pm (unchanged) | Makefile:457: recipe for target 'manifypods' failed | make[1]: *** [manifypods] Illegal instruction So set it to use the -native ones instead of those from the target build. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index ec4d2140e7..3ca0f53964 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -94,6 +94,11 @@ HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl-native/perl${PV}"
# Where to find .so files - use the -native versions not those from the target build
export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
+# Where to find perl @INC/#include files
+# - use the -native versions not those from the target build
+export PERL_LIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
+export PERL_ARCHLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
+
# LDFLAGS for shared libraries
export LDDLFLAGS = "${LDFLAGS} -shared"