aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoor <noor_ahsan@mentor.com>2014-09-30 21:03:43 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-10 10:39:12 +0100
commitb853cead2e0965b9797b40d6b59bed67804f459f (patch)
treebc1369cfa891ec52770ad6ca52bd8d2c8942c885
parentf04576c761c568083be1143f421e29fc2365846a (diff)
downloadopenembedded-core-contrib-b853cead2e0965b9797b40d6b59bed67804f459f.tar.gz
latencytop: Creates x11 PACKAGECONFIG.
* Creates x11 packageconfig and update DEPENDS and EXTRA_OEMAKE_X for better handling. Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
-rw-r--r--meta/recipes-kernel/latencytop/latencytop_0.5.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-kernel/latencytop/latencytop_0.5.bb b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
index 516e2c5267..e910a96f43 100644
--- a/meta/recipes-kernel/latencytop/latencytop_0.5.bb
+++ b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.latencytop.org/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://latencytop.c;endline=23;md5=ee9ea9b1415356e5734adad4a87dc7fa"
-DEPENDS = "virtual/libintl ncurses glib-2.0 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
+DEPENDS = "virtual/libintl ncurses glib-2.0"
PR = "r3"
@@ -15,7 +15,11 @@ SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
SRC_URI[md5sum] = "73bb3371c6ee0b0e68e25289027e865c"
SRC_URI[sha256sum] = "9e7f72fbea7bd918e71212a1eabaad8488d2c602205d2e3c95d62cd57e9203ef"
-EXTRA_OEMAKE_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'HAS_GTK_GUI=1', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+
+PACKAGECONFIG[x11] = ",,gtk+"
+
+EXTRA_OEMAKE_X = "${@bb.utils.contains('PACKAGECONFIG', 'x11', 'HAS_GTK_GUI=1', '', d)}"
CFLAGS += "${LDFLAGS}"