aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-18 13:33:49 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-20 09:20:05 +0000
commit1d8c04256603c7cb5138018c6c662f4573a6c9ea (patch)
tree43ac2ab673c31a64467d807916b632f2d00238e9
parent18dbd28d638ee4b50de5a7a1aca00f3277fdb42e (diff)
downloadopenembedded-core-contrib-1d8c04256603c7cb5138018c6c662f4573a6c9ea.tar.gz
strace: fix --disable-aio configure option
Remove the original unconditional check for libaio.h, since it's included in the newly added conditional check. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/strace/strace/strace-add-configure-options.patch14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch b/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
index a3f8ec463d..84b9f9cab5 100644
--- a/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
+++ b/meta/recipes-devtools/strace/strace/strace-add-configure-options.patch
@@ -12,7 +12,19 @@ diff --git a/configure.ac b/configure.ac
index e73958c..9099370 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -745,6 +745,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes;
+@@ -303,11 +303,6 @@ AC_CHECK_MEMBERS([struct sysinfo.totalhi
+
+ AC_CHECK_TYPES([struct flock64],,, [#include <fcntl.h>])
+
+-AC_CHECK_HEADERS([libaio.h], [
+- AC_CHECK_MEMBERS([struct iocb.u.c.flags],,, [#include <libaio.h>])
+- AC_CHECK_DECLS([IO_CMD_PWRITE, IO_CMD_PWRITEV],,, [#include <libaio.h>])
+-])
+-
+ AC_CHECK_HEADERS([linux/input.h], [
+ AC_CHECK_MEMBERS([struct input_absinfo.resolution],,, [#include <linux/input.h>])
+ ])
+@@ -745,6 +740,20 @@ if test "x$ac_cv_lib_dl_dladdr" = xyes;
fi
AC_SUBST(dl_LIBS)