aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Ellis <scott@jumpnowtek.com>2016-01-18 05:42:48 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-19 17:37:23 +0000
commit025c348d0f12be9405a8d14e9ef6787e37ee7a23 (patch)
tree52056e63e2aee08f2c0da553eb1049b4b301254f
parentbfc8304d4c10b5601a618011893369831baaf511 (diff)
downloadopenembedded-core-contrib-025c348d0f12be9405a8d14e9ef6787e37ee7a23.tar.gz
coreutils: Add xattr PACKAGECONFIG
From Yocto poky where it also stops this warning WARNING: QA Issue: coreutils rdepends on libattr, but it isn't a build dependency? [build-deps] Signed-off-by: Scott Ellis <scott@jumpnowtek.com>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.24.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.24.bb b/meta/recipes-core/coreutils/coreutils_8.24.bb
index f042346241..6a09c594dc 100644
--- a/meta/recipes-core/coreutils/coreutils_8.24.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.24.bb
@@ -28,14 +28,19 @@ SRC_URI[manpages.sha256sum] = "cf0333b5f134a331e0b46e2ddf90666f8bdc3281c1ca2c7cc
EXTRA_OECONF_class-native = "--without-gmp"
EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
-# acl is not a default feature
+# acl and xattr are not default features
#
-PACKAGECONFIG_class-target ??= "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG_class-target ??= "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
+"
+
PACKAGECONFIG_class-native ??= ""
# with, without, depends, rdepends
#
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
+PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
# [ df mktemp base64 gets a special treatment and is not included in this
bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \