aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-10-01 00:43:36 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-01 09:05:02 +0100
commit81bb7a163d7e3c0bdcc72894ef731521d58edf90 (patch)
treee9dc3d201b3d4186adfa444bfd36f81fd9ac7e8c
parent6957ce3e726de5dbdcf3e94c5919916d88736e8d (diff)
downloadopenembedded-core-contrib-81bb7a163d7e3c0bdcc72894ef731521d58edf90.tar.gz
perf: fix undefined pr_* routines
When cross compiling libunwind support for ARM a missing debug include means that pr* macros are not expanded, and hence link failures on the undefined functions. Since we must be compatible with many versions of the kernel and perf, we sed the proper include into the files, while the permanent fix goes upstream to the mainline kernel. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index ea7571aa8e..3771cdb3e9 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -145,9 +145,14 @@ do_configure_prepend () {
if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
fi
- # 3.17-rc1+ has a include issue for powerpc. Temporarily sed in the appropriate include
- if [ -e "${S}/tools/perf/arch/powerpc/util/skip-callchain-idx.c" ]; then
- sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/powerpc/util/skip-callchain-idx.c
+
+ # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
+ if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
+ sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
+ fi
+ if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
+ sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
+ sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
fi
}