aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-03-18 23:29:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-20 23:51:27 +0000
commite084060b59f2ad2ca5e3896afb2ff2dfb665cc67 (patch)
tree9b111be9a5cf4dc9555f156b7fa4298609b360b4
parentd3a656dd2a276a743925f55935789357c4cb4d97 (diff)
downloadopenembedded-core-contrib-e084060b59f2ad2ca5e3896afb2ff2dfb665cc67.tar.gz
gst-plugins-good: fix nondeterministic udev dependency
Make the v4l PACKAGECONFIG option control building of the video4linux2 plug-in (not use of libv4l, as it did before) and enable by default. Add a separate libv4l PACKAGECONFIG to control use of libv4l (disabled by default since libv4l is not part of oe-core). The default config for gst-plugins-good and gstreamer1.0-plugins-good is now aligned with regards to v4l, ie: v4l support: enabled by default v4l use of libgudev: enabled by default v4l use of libv4l2: disabled by default This commit fixes the following build-deps QA Warnings: WARNING: QA Issue: gst-plugins-good-video4linux2 rdepends on libudev, but it isn't a build dependency? [build-deps] WARNING: QA Issue: gst-plugins-good-video4linux2 rdepends on libgudev, but it isn't a build dependency? [build-deps] Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
index 85f2196fd4..af18281715 100644
--- a/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
PR = "r8"
-PACKAGECONFIG ?= "jpeg \
+PACKAGECONFIG ?= "jpeg v4l \
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
"
@@ -16,7 +16,9 @@ PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
PACKAGECONFIG[gdkpixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
-PACKAGECONFIG[v4l] = "--with-libv4l2,--without-libv4l2,libv4l"
+PACKAGECONFIG[v4l] = "--enable-gst_v4l2 --with-gudev,--disable-gst_v4l2 --without-gudev,udev"
+# sub-feature of v4l, but control separately since libv4l is not part of oe-core
+PACKAGECONFIG[libv4l] = "--with-libv4l2,--without-libv4l2,libv4l"
PACKAGECONFIG[bzip2] = "--enable-bz2,--disable-bz2,bzip2"
PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
PACKAGECONFIG[x11] = "--enable-x,--disable-x,virtual/libx11 libxfixes libxdamage"