aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryanjun.zhu <yanjun.zhu@windriver.com>2014-06-06 15:19:47 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-10 17:14:36 +0100
commit7a3b7d70a0cc4cdef81bb63fdac7de8f1309d1fc (patch)
tree75c2ad81ec4207a0d1a5d458a4c61311f85e099e
parent38ac187881266e6349084ee983046e311fb293e9 (diff)
downloadopenembedded-core-contrib-7a3b7d70a0cc4cdef81bb63fdac7de8f1309d1fc.tar.gz
python-gst: link python shared library to config directory
python-gst needs python shared library in python config directory. Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-gst_0.10.22.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gst_0.10.22.bb b/meta/recipes-devtools/python/python-gst_0.10.22.bb
index a551adbfa6..2a5f2b3239 100644
--- a/meta/recipes-devtools/python/python-gst_0.10.22.bb
+++ b/meta/recipes-devtools/python/python-gst_0.10.22.bb
@@ -21,3 +21,9 @@ EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
FILES_${PN} += "${datadir}/gst-python"
FILES_${PN}-dev += "${datadir}/gst-python/0.10/defs"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/ ${libdir}/gstreamer-0.10/.debug/"
+
+do_configure_prepend() {
+ if [ `find ${STAGING_LIBDIR} -name libpython*.so` ]; then
+ ln -sf ${STAGING_LIBDIR}/libpython*.so `find ${STAGING_LIBDIR} -name libpython*.a -exec dirname {} \;`
+ fi
+}