aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <henning@itconsulting-heinold.de>2014-06-09 23:21:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 12:30:30 +0100
commit17bf25adad715754de589d2ae54f97c07f5dafde (patch)
treef9964399327c6e9aa1706b9b8ad0dd1574d2fa1a
parente4b01d651cf94185cfb285a7b64292b26b74c6bb (diff)
downloadopenembedded-core-contrib-17bf25adad715754de589d2ae54f97c07f5dafde.tar.gz
perf: fix broken shell comparsion in do_install
The patch was sponsored by sysmocom Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index ef21b6c9c2..9996f663cd 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -112,7 +112,7 @@ do_install() {
unset CFLAGS
oe_runmake DESTDIR=${D} install
# we are checking for this make target to be compatible with older perf versions
- if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then
+ if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0" ]; then
oe_runmake DESTDIR=${D} install-python_ext
fi
}