aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-22 00:36:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-29 18:14:52 +0000
commitd178082b0577682ffd6549d8867636cbec3a7d04 (patch)
tree0cd5598555e72dcc1d7cd1e2cd31033c18061860
parent80d015442b5efdf796dbe0b30642f168d5482dca (diff)
downloadopenembedded-core-contrib-d178082b0577682ffd6549d8867636cbec3a7d04.tar.gz
libdrm: Refresh patch to match upstream submission
The version submitted upstream has been updated to this one after feedback Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-graphics/drm/libdrm/0001-tests-kms-steal-crtc-Include-sys-select.h.patch83
1 files changed, 73 insertions, 10 deletions
diff --git a/meta/recipes-graphics/drm/libdrm/0001-tests-kms-steal-crtc-Include-sys-select.h.patch b/meta/recipes-graphics/drm/libdrm/0001-tests-kms-steal-crtc-Include-sys-select.h.patch
index c18228ee0f..e4ecbac16c 100644
--- a/meta/recipes-graphics/drm/libdrm/0001-tests-kms-steal-crtc-Include-sys-select.h.patch
+++ b/meta/recipes-graphics/drm/libdrm/0001-tests-kms-steal-crtc-Include-sys-select.h.patch
@@ -1,33 +1,96 @@
-From 46fb5516fb0ab17bcf46a0306a11e8966bb36e14 Mon Sep 17 00:00:00 2001
+From fb53d7a1be116a172b56625f290fcf88b6d158ca Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 29 Dec 2015 22:17:21 +0000
-Subject: [PATCH] tests/kms-steal-crtc: Include sys/select.h
+Date: Wed, 20 Jan 2016 05:23:00 +0000
+Subject: [PATCH] tests: Include sys/select.h
-Fixes errors e.g.
+Used in compliance with POSIX 2001/2008
+Fixes errors e.g.
error: implicit declaration of function 'select'
-and missing definitions of FD_* defines
+and helps with missing definitions of FD_* defines
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Reviewed-by: Thierry Reding <thierry.reding@gmail.com>
---
Upstream-Status: Submitted
- tests/kms/kms-steal-crtc.c | 1 +
- 1 file changed, 1 insertion(+)
+ configure.ac | 2 +-
+ tests/kms/kms-steal-crtc.c | 3 +++
+ tests/kms/kms-universal-planes.c | 3 +++
+ tests/modetest/modetest.c | 3 +++
+ tests/vbltest/vbltest.c | 3 +++
+ 5 files changed, 13 insertions(+), 1 deletion(-)
+diff --git a/configure.ac b/configure.ac
+index 057a846..258e2f6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -53,7 +53,7 @@ AC_USE_SYSTEM_EXTENSIONS
+ AC_SYS_LARGEFILE
+ AC_FUNC_ALLOCA
+
+-AC_CHECK_HEADERS([sys/mkdev.h sys/sysctl.h])
++AC_CHECK_HEADERS([sys/mkdev.h sys/sysctl.h sys/select.h])
+
+ # Initialize libtool
+ LT_PREREQ([2.2])
diff --git a/tests/kms/kms-steal-crtc.c b/tests/kms/kms-steal-crtc.c
-index 2f7f327..24d70ab 100644
+index 2f7f327..497772e 100644
--- a/tests/kms/kms-steal-crtc.c
+++ b/tests/kms/kms-steal-crtc.c
-@@ -31,6 +31,7 @@
+@@ -31,6 +31,9 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
++#ifdef HAVE_SYS_SELECT_H
++#include <sys/select.h>
++#endif
+
+ #include <drm_fourcc.h>
+
+diff --git a/tests/kms/kms-universal-planes.c b/tests/kms/kms-universal-planes.c
+index 9151231..d8e5fc4 100644
+--- a/tests/kms/kms-universal-planes.c
++++ b/tests/kms/kms-universal-planes.c
+@@ -32,6 +32,9 @@
#include <stdio.h>
#include <string.h>
#include <unistd.h>
++#ifdef HAVE_SYS_SELECT_H
+#include <sys/select.h>
++#endif
#include <drm_fourcc.h>
+ #include "xf86drm.h"
+diff --git a/tests/modetest/modetest.c b/tests/modetest/modetest.c
+index 22e3e81..d5a4062 100644
+--- a/tests/modetest/modetest.c
++++ b/tests/modetest/modetest.c
+@@ -55,6 +55,9 @@
+ #include <errno.h>
+ #include <sys/poll.h>
+ #include <sys/time.h>
++#ifdef HAVE_SYS_SELECT_H
++#include <sys/select.h>
++#endif
+
+ #include "xf86drm.h"
+ #include "xf86drmMode.h"
+diff --git a/tests/vbltest/vbltest.c b/tests/vbltest/vbltest.c
+index 1833321..086407e 100644
+--- a/tests/vbltest/vbltest.c
++++ b/tests/vbltest/vbltest.c
+@@ -37,6 +37,9 @@
+ #include <errno.h>
+ #include <sys/poll.h>
+ #include <sys/time.h>
++#ifdef HAVE_SYS_SELECT_H
++#include <sys/select.h>
++#endif
+ #include "xf86drm.h"
+ #include "xf86drmMode.h"
--
-2.6.4
+2.7.0