aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-02-01 05:08:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-02 14:42:14 +0000
commit17566da0b86cc282d5e598af54e73555c121beb3 (patch)
tree7896b7d663ea7de25fda717d9c354d768574ed1d
parent94f780e889f194b67a48587ac68b3200288bee10 (diff)
downloadopenembedded-core-contrib-17566da0b86cc282d5e598af54e73555c121beb3.tar.gz
boost: Fix build on soft-float ABI arm systems
We get errors like ./boost/test/execution_monitor.hpp:490:27: error: 'FE_DIVBYZERO' was not declared in this scope BOOST_FPE_DIVBYZERO = FE_DIVBYZERO, on musl, rightly because FPU is not used on soft-float systems Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/boost/boost/consider-hardfp.patch19
-rw-r--r--meta/recipes-support/boost/boost_1.60.0.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/boost/consider-hardfp.patch b/meta/recipes-support/boost/boost/consider-hardfp.patch
new file mode 100644
index 0000000000..66808a69dd
--- /dev/null
+++ b/meta/recipes-support/boost/boost/consider-hardfp.patch
@@ -0,0 +1,19 @@
+When using soft-float, on ARM we should not expect the FE_* symbols
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: boost_1_60_0/boost/test/execution_monitor.hpp
+===================================================================
+--- boost_1_60_0.orig/boost/test/execution_monitor.hpp
++++ boost_1_60_0/boost/test/execution_monitor.hpp
+@@ -484,7 +484,8 @@ enum masks {
+ BOOST_FPE_UNDERFLOW = EM_UNDERFLOW|EM_DENORMAL,
+
+ BOOST_FPE_ALL = MCW_EM,
+-#elif defined(BOOST_NO_FENV_H) || defined(BOOST_CLANG)
++#elif defined(BOOST_NO_FENV_H) || defined(BOOST_CLANG) \
++ || defined(__ARM_PCS)
+ BOOST_FPE_ALL = 1,
+ #else
+ BOOST_FPE_DIVBYZERO = FE_DIVBYZERO,
diff --git a/meta/recipes-support/boost/boost_1.60.0.bb b/meta/recipes-support/boost/boost_1.60.0.bb
index e7b91dcc72..4d824c85b5 100644
--- a/meta/recipes-support/boost/boost_1.60.0.bb
+++ b/meta/recipes-support/boost/boost_1.60.0.bb
@@ -4,4 +4,5 @@ include boost.inc
SRC_URI += "\
file://arm-intrinsics.patch \
file://0001-Do-not-qualify-fenv.h-names-that-might-be-macros.patch;striplevel=2 \
+ file://consider-hardfp.patch \
"