aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi Zhou <li.zhou@windriver.com>2015-04-30 17:34:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-03 11:39:46 +0100
commit1bb2c58ef7de3a1d52b4a29ca3cc230defe6c21d (patch)
tree5b4a42c068fdf9f2b9d77fd735fa485df4e23292
parent4a7bd79b5100a496c9b1597b57d6dc18ba2b9c83 (diff)
downloadopenembedded-core-contrib-1bb2c58ef7de3a1d52b4a29ca3cc230defe6c21d.tar.gz
boost/libxslt: Enable nativesdk to unbreak <bitbake universe>
When run <make universe.fetchall>, the make will be broken because nativesdk-boost and nativesdk-libxslt don't exist. nativesdk-boost is depended by nativesdk-curlpp. nativesdk-libxslt is depended by nativesdk-python-lxml. In condition that meta-openembedded is compiled in. Add nativesdk building for boost and libxslt. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/boost/boost.inc2
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.28.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/boost/boost.inc b/meta/recipes-support/boost/boost.inc
index 6b42133aed..7628e37d6f 100644
--- a/meta/recipes-support/boost/boost.inc
+++ b/meta/recipes-support/boost/boost.inc
@@ -181,4 +181,4 @@ do_install() {
}
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
index ded883e457..166bcd86e7 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.28.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -43,4 +43,4 @@ do_install_append_class-native () {
FILES_${PN} += "${libdir}/libxslt-plugins"
FILES_${PN}-dev += "${libdir}/xsltConf.sh"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"