aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2015-03-12 20:18:56 +1100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-16 17:38:51 +0000
commit0752c79282b1cc9699743e719518e6c341d50a3a (patch)
tree1ef91eb676d26ea080c310d4b1c618bbe8e4171a
parent18304e03c8ab8de94b6001a8a5677b57862da0f4 (diff)
downloadopenembedded-core-contrib-0752c79282b1cc9699743e719518e6c341d50a3a.tar.gz
systemd: fix /var/log/journal ownership
The ownership needs to be explicitly set otherwise it inherits the user and group id of the build user. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/systemd/systemd_219.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_219.bb b/meta/recipes-core/systemd/systemd_219.bb
index 238ee6707b..ff29a3fecf 100644
--- a/meta/recipes-core/systemd/systemd_219.bb
+++ b/meta/recipes-core/systemd/systemd_219.bb
@@ -154,6 +154,8 @@ do_install() {
sed -i s%@UDEVD@%${rootlibexecdir}/systemd/systemd-udevd% ${D}${sysconfdir}/init.d/systemd-udevd
fi
+ chown root:systemd-journal ${D}/${localstatedir}/log/journal
+
# Delete journal README, as log can be symlinked inside volatile.
rm -f ${D}/${localstatedir}/log/README