aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-07-01 15:51:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-03 17:38:48 +0100
commitc67dc89179977b2df80f25ebf66b7e983819a833 (patch)
tree797d5cea8b6d96f160970a660dadb3e458edcf51
parente017ae71dad4837b0d22f291b0b0e0949075f822 (diff)
downloadopenembedded-core-contrib-c67dc89179977b2df80f25ebf66b7e983819a833.tar.gz
libxml-parser-perl: fix do_compile failed with unrecognized option '-Wl, -O1'
Use '${CCLD}' as '${LD}' which the cpan was doing. ... i586-poky-linux-ld: unrecognized option '-Wl,-O1' i586-poky-linux-ld: use the --help option for usage information ... Also fix do_configure warnings ... '--SYSROOT' is not a known MakeMaker parameter name. '-MARCH' is not a known MakeMaker parameter name. ... Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
index 43a8a84518..26241e884c 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
@@ -13,7 +13,7 @@ SRC_URI[sha256sum] = "b48197cd2265a26c5f016489f11a7b450d8833cb8b3d6a46ee15975740
S = "${WORKDIR}/XML-Parser-${PV}"
-EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR} CC=${CC} LD=${LD} FULL_AR=${AR}"
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR} CC='${CC}' LD='${CCLD}' FULL_AR='${AR}'"
inherit cpan