aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-06-08 02:30:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-14 12:56:32 +0100
commit0a78e2051e6e735e3a47a8d46d150f5e62ba505c (patch)
treed8e4c10688dc19ecdcc35338b1e49bec0004a819
parent2a6f88d51414993d18096f7f0dc27c0b862240bc (diff)
downloadopenembedded-core-contrib-0a78e2051e6e735e3a47a8d46d150f5e62ba505c.tar.gz
python-mako: rm -df -> rmdir
The old rm (e.g., Ubuntu 12.04's) doesn't has -d option, use rmdir to make it work. BTW., the "-f" option in rm -df doesn't make any sense. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/python/python-mako_1.0.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-mako_1.0.4.bb b/meta/recipes-devtools/python/python-mako_1.0.4.bb
index b10b3c3d77..230044e1a2 100644
--- a/meta/recipes-devtools/python/python-mako_1.0.4.bb
+++ b/meta/recipes-devtools/python/python-mako_1.0.4.bb
@@ -13,5 +13,5 @@ BBCLASSEXTEND = "native nativesdk"
# The same utility is packaged in python3-mako, so it would conflict
do_install_append() {
rm -f ${D}${bindir}/mako-render
- rm -df ${D}${bindir}
+ rmdir ${D}${bindir}
}