aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-07 12:18:13 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-07 12:37:05 +0100
commit90540692c40719b757b80bdc6e78e679a3df83a7 (patch)
tree5cd10d13ce3f43aa6413122992110a02122e381f
parent4fd4b2eafb5f4ff2ef85d7f5ff3238a41c34313b (diff)
downloadopenembedded-core-contrib-90540692c40719b757b80bdc6e78e679a3df83a7.tar.gz
python: Fix RPATH QA issue on non-gplv3 builds
On non-gplv3 builds, gdbm gets built different due to the different version which triggers a different codepath in python's db support and then hence triggers an invalid RPATH QA issue. This change extends the appropriate patch to cover the code paths we need it to cover and avoid adding the problematic RPATH. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch28
1 files changed, 16 insertions, 12 deletions
diff --git a/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch b/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
index 4b8953a137..dfd346f86e 100644
--- a/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
+++ b/meta/recipes-devtools/python/python/python-2.7.3-remove-bsdb-rpath.patch
@@ -1,15 +1,14 @@
-Remove the RPTH to avoid QA issue warning.
+Remove the RPATH to avoid QA issue warning.
+RP: Added secondary unnecessary rpath to the list 2012/8/7
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
----
- setup.py | 1 -
- 1 files changed, 0 insertions(+), 1 deletions(-)
-diff --git a/setup.py b/setup.py
-index 83b5e56..1fd5487 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1025,7 +1025,6 @@ class PyBuildExt(build_ext):
+
+Index: Python-2.7.3/setup.py
+===================================================================
+--- Python-2.7.3.orig/setup.py 2012-08-07 10:41:58.560132529 +0000
++++ Python-2.7.3/setup.py 2012-08-07 11:09:47.852094515 +0000
+@@ -1042,7 +1042,6 @@
exts.append(Extension('_bsddb', ['_bsddb.c'],
depends = ['bsddb.h'],
library_dirs=dblib_dir,
@@ -17,6 +16,11 @@ index 83b5e56..1fd5487 100644
include_dirs=db_incs,
libraries=dblibs))
else:
---
-1.7.4
-
+@@ -1252,7 +1251,6 @@
+ print "building dbm using bdb"
+ dbmext = Extension('dbm', ['dbmmodule.c'],
+ library_dirs=dblib_dir,
+- runtime_library_dirs=dblib_dir,
+ include_dirs=db_incs,
+ define_macros=[
+ ('HAVE_BERKDB_H', None),