aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2015-04-10 16:54:40 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 14:57:43 +0100
commit25b4cac50ba05a8faeb3b2013253103b98e5f533 (patch)
treebb836a69ce9ea4c74f41f544afe9c10aa069ca27
parent6a78a1f14486f76f6aaad770d630136a6345e7bd (diff)
downloadopenembedded-core-contrib-25b4cac50ba05a8faeb3b2013253103b98e5f533.tar.gz
openembedded-core-contrib-25b4cac50ba05a8faeb3b2013253103b98e5f533.tar.bz2
openembedded-core-contrib-25b4cac50ba05a8faeb3b2013253103b98e5f533.zip
librsvg: Upgrade 0.40.6 -> 0.40.9
* modify gtk-option patch so it's for configure.ac and not configure.in Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-gnome/librsvg/librsvg/gtk-option.patch32
-rw-r--r--meta/recipes-gnome/librsvg/librsvg_2.40.9.bb (renamed from meta/recipes-gnome/librsvg/librsvg_2.40.6.bb)4
2 files changed, 19 insertions, 17 deletions
diff --git a/meta/recipes-gnome/librsvg/librsvg/gtk-option.patch b/meta/recipes-gnome/librsvg/librsvg/gtk-option.patch
index d44bdd32093..3835015ce2a 100644
--- a/meta/recipes-gnome/librsvg/librsvg/gtk-option.patch
+++ b/meta/recipes-gnome/librsvg/librsvg/gtk-option.patch
@@ -1,27 +1,29 @@
-Upstream-Status: Submitted [https://bugzilla.gnome.org/show_bug.cgi?id=712693]
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From 18917f7fd3160afe06019f4b6234aeb78a3fdb4e Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Tue, 19 Nov 2013 16:00:29 +0000
+From 85d4af4451283f388e1e101ee4710bb19854154d Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Fri, 10 Apr 2015 16:49:43 +0300
Subject: [PATCH] configure: add option to enable/disable use of GTK+
Distro packagers like predictability and automatically detected optional
dependencies are not predicable. Add a --with-gtk3 option (default to "auto")
for forcibly controlling whether GTK+ will be used or not.
+Upstream-Status: Submitted [https://bugzilla.gnome.org/show_bug.cgi?id=712693]
+
Signed-off-by: Ross Burton <ross.burton@intel.com>
-https://bugzilla.gnome.org/show_bug.cgi?id=712693
+
+Forward-ported to 2.40.9
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
---
- configure.in | 17 +++++++++++------
+ configure.ac | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)
-diff --git a/configure.in b/configure.in
-index f7a89dc..1498f72 100644
---- a/configure.in
-+++ b/configure.in
-@@ -119,17 +119,22 @@ AC_CHECK_FUNCS(strtok_r)
+diff --git a/configure.ac b/configure.ac
+index e86c052..16b0e34 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -128,17 +128,22 @@ AC_CHECK_FUNCS(strtok_r)
# GTK
# ===========================================================================
@@ -49,7 +51,7 @@ index f7a89dc..1498f72 100644
dnl ===========================================================================
dnl GDK-Pixbuf SVG loader
-@@ -305,6 +310,6 @@ librsvg-$VERSION
+@@ -289,6 +294,6 @@ librsvg-$VERSION
Build introspectable bindings: ${found_introspection}
Build Vala bindings: ${enable_vala}
Build GdkPixbuf loader: ${enable_pixbuf_loader}
@@ -58,5 +60,5 @@ index f7a89dc..1498f72 100644
Build miscellaenous tools: ${build_misc_tools}
"
--
-1.7.10.4
+2.1.4
diff --git a/meta/recipes-gnome/librsvg/librsvg_2.40.6.bb b/meta/recipes-gnome/librsvg/librsvg_2.40.9.bb
index 483d30980f9..9a14f29ca28 100644
--- a/meta/recipes-gnome/librsvg/librsvg_2.40.6.bb
+++ b/meta/recipes-gnome/librsvg/librsvg_2.40.9.bb
@@ -16,8 +16,8 @@ GNOME_COMPRESS_TYPE = "xz"
SRC_URI += "file://gtk-option.patch"
-SRC_URI[archive.md5sum] = "259fd160b47ec11f3c27d7e18e507c99"
-SRC_URI[archive.sha256sum] = "8af349f241677b04b7a1ea6b9b33a6343e781bcccc8a09d00208a47342584f06"
+SRC_URI[archive.md5sum] = "31df15e3beaa8fbbf538ca3c52b400d2"
+SRC_URI[archive.sha256sum] = "13964c5d35357552b47d365c34215eee0a63bf0e6059b689f048648c6bf5f43a"
EXTRA_OECONF = "--disable-introspection --disable-vala"