aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2015-03-05 08:48:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-09 16:05:07 +0000
commit40a4f83d3791658789da8559c554b93b50db81c0 (patch)
tree2726d4734c066b0ef871fd3a809609b4a983e9dc
parentb1b9a269ff94d80622f1c2a447568641039dc9ce (diff)
downloadopenembedded-core-contrib-40a4f83d3791658789da8559c554b93b50db81c0.tar.gz
opkg: Fix error when recompiled
If this package were ever recompiled, i.e. do_compile is rerun as a result of a compiler change, etc., the 'opkg.conf' file would be incorrectly updated, leading to an error: * opkg_conf_set_option: Duplicate option lists_dir, using first seen value "/var/lib/opkg". Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.2.4.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.2.4.bb b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
index 8455eac78d..447f3f6cc2 100644
--- a/meta/recipes-devtools/opkg/opkg_0.2.4.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
@@ -47,13 +47,10 @@ do_configure_prepend() {
sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
}
-do_compile_append () {
- echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
-}
-
do_install_append () {
install -d ${D}${sysconfdir}/opkg
install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
+ echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${D}${sysconfdir}/opkg/opkg.conf
# We need to create the lock directory
install -d ${D}${OPKGLIBDIR}/opkg