aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-05-19 16:38:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-20 08:13:04 +0100
commitfb426a1f5a103a1dc096977533dfbec2aefe07ae (patch)
treeaa2a7f4a6a886580dbd0316bc990788e5db6e1dd
parent87d487ea4fdfb6cd30e3b3fad47732db12e86f23 (diff)
downloadopenembedded-core-contrib-fb426a1f5a103a1dc096977533dfbec2aefe07ae.tar.gz
pcmciautils: fix the parallel building issue
The building failure still display after upstream commit 055a5bbfc[ pcmciautils: fix for parallel build], so refix it. Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/pcmciautils/pcmciautils-018/0001-fix-a-parallel-building-issue.patch45
-rw-r--r--meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch41
-rw-r--r--meta/recipes-bsp/pcmciautils/pcmciautils_018.bb2
3 files changed, 46 insertions, 42 deletions
diff --git a/meta/recipes-bsp/pcmciautils/pcmciautils-018/0001-fix-a-parallel-building-issue.patch b/meta/recipes-bsp/pcmciautils/pcmciautils-018/0001-fix-a-parallel-building-issue.patch
new file mode 100644
index 0000000000..7b010400f7
--- /dev/null
+++ b/meta/recipes-bsp/pcmciautils/pcmciautils-018/0001-fix-a-parallel-building-issue.patch
@@ -0,0 +1,45 @@
+From 5a793a1a9fb3477719aabf7e27ff22ed1acdf559 Mon Sep 17 00:00:00 2001
+From: Roy Li <rongqing.li@windriver.com>
+Date: Tue, 19 May 2015 15:54:24 +0800
+Subject: [PATCH] fix a parallel building issue
+
+Fixed:
+| src/lex_config.c:34:25: fatal error: yacc_config.h: No such file or directory
+|
+| #include "yacc_config.h"
+| ^
+| compilation terminated.
+
+And:
+Compiling lex_config.c.
+ src/lex_config.l:34:25: fatal error: yacc_config.h: No such file or directory
+
+Upstream-Status: Pending
+
+there are two Makefile rules to generate lex_config.o, one is to generate
+lex_config.o other is to generate src/lex_config.o, so we can remove one.
+and add the needed dependence for lex_config.o
+
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ Makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d45fdc3..4c53bc2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -246,8 +246,7 @@ $(PCMCIA_SOCKET_STARTUP): $(LIBC) src/startup.o src/yacc_config.o src/lex_config
+ $(QUIET) $(LD) $(LDFLAGS) -o $@ $(CRT0) src/startup.o src/yacc_config.o src/lex_config.o $(LIB_OBJS) $(ARCH_LIB_OBJS)
+ $(QUIET) $(STRIPCMD) $@
+
+-yacc_config.o lex_config.o: %.o: %.c
+- $(CC) -c -MD -O -pipe $(CPPFLAGS) $<
++src/lex_config.o:src/yacc_config.h
+
+ debugtools: ccdv $(CBDUMP) $(CISDUMP)
+
+--
+1.9.1
+
diff --git a/meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch b/meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch
deleted file mode 100644
index d0bb3d6f1a..0000000000
--- a/meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 1b8ad348f8c712c8e0c16c49cc1c8e577e4d6d3e Mon Sep 17 00:00:00 2001
-From: Robert Yang <liezhi.yang@windriver.com>
-Date: Thu, 5 Feb 2015 01:16:30 -0800
-Subject: [PATCH] Makefile: fix for parallel build
-
-Fixed:
-| src/lex_config.c:34:25: fatal error: yacc_config.h: No such file or directory
-|
-| #include "yacc_config.h"
-| ^
-| compilation terminated.
-
-And:
-Compiling lex_config.c.
- src/lex_config.l:34:25: fatal error: yacc_config.h: No such file or directory
-
-Upstream-Status: Pending
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- Makefile | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index d45fdc3..963453a 100644
---- a/Makefile
-+++ b/Makefile
-@@ -246,7 +246,9 @@ $(PCMCIA_SOCKET_STARTUP): $(LIBC) src/startup.o src/yacc_config.o src/lex_config
- $(QUIET) $(LD) $(LDFLAGS) -o $@ $(CRT0) src/startup.o src/yacc_config.o src/lex_config.o $(LIB_OBJS) $(ARCH_LIB_OBJS)
- $(QUIET) $(STRIPCMD) $@
-
--yacc_config.o lex_config.o: %.o: %.c
-+lex_config.o: lex_config.c yacc_config.h
-+ $(CC) -c -MD -O -pipe $(CPPFLAGS) $<
-+yacc_config.o: yacc_config.c
- $(CC) -c -MD -O -pipe $(CPPFLAGS) $<
-
- debugtools: ccdv $(CBDUMP) $(CISDUMP)
---
-1.7.9.5
-
diff --git a/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb b/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb
index fc76c44626..24ceed87a9 100644
--- a/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb
+++ b/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb
@@ -1,7 +1,7 @@
require pcmciautils.inc
SRC_URI += "file://makefile_fix.patch \
- file://Makefile-fix-for-parallel-build.patch \
+ file://0001-fix-a-parallel-building-issue.patch \
"
SRC_URI[md5sum] = "5d85669b3440baa4532363da6caaf1b4"