summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-06-03 14:17:09 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-08 17:30:50 +0100
commite40cd13e6f7b106ee0ee56ddc3c3ba6e63f9c432 (patch)
treef536d8fdd4579bf9c06f2a20b9fd3aecbacec339
parent4d033fdc5e754e22edb2e9074e30e58847c4b791 (diff)
downloadopenembedded-core-contrib-e40cd13e6f7b106ee0ee56ddc3c3ba6e63f9c432.tar.gz
openembedded-core-contrib-e40cd13e6f7b106ee0ee56ddc3c3ba6e63f9c432.tar.bz2
openembedded-core-contrib-e40cd13e6f7b106ee0ee56ddc3c3ba6e63f9c432.zip
alsa-plugins: enable alsa-plugins-pulseaudio-conf conditionally
If pulseaudio isn't enabled, the alsa-plugins-pulseaudio-conf package is unnecessary. This change fixes these warnings, when pulseaudio isn't enabled: WARNING: QA Issue: alsa-plugins-pulseaudio-conf rdepends on libasound-module-conf-pulse, but it isn't a build dependency? [build-deps] WARNING: QA Issue: alsa-plugins-pulseaudio-conf rdepends on libasound-module-ctl-pulse, but it isn't a build dependency? [build-deps] WARNING: QA Issue: alsa-plugins-pulseaudio-conf rdepends on libasound-module-pcm-pulse, but it isn't a build dependency? [build-deps] Reported-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tanu Kaskinen <tanu.kaskinen@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-multimedia/alsa/alsa-plugins_1.0.29.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-plugins_1.0.29.bb b/meta/recipes-multimedia/alsa/alsa-plugins_1.0.29.bb
index af56aeb84e..85df8bf353 100644
--- a/meta/recipes-multimedia/alsa/alsa-plugins_1.0.29.bb
+++ b/meta/recipes-multimedia/alsa/alsa-plugins_1.0.29.bb
@@ -40,7 +40,7 @@ PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio
PACKAGECONFIG[samplerate] = "--enable-samplerate,--disable-samplerate,libsamplerate0"
PACKAGECONFIG[speex] = "--with-speex=lib,--with-speex=no,speex"
-PACKAGES += "alsa-plugins-pulseaudio-conf"
+PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'alsa-plugins-pulseaudio-conf', '', d)}"
PACKAGES_DYNAMIC = "^libasound-module-.*"