aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-28 02:22:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-30 22:25:11 +0100
commit60c1f76f65060cbea458b06f9719a2536f50474e (patch)
tree271efa23afb6343e70a127c61d8373611e0072f8
parent787acab921b41082c4e8ca87bc40ae4e60954af8 (diff)
downloadopenembedded-core-contrib-60c1f76f65060cbea458b06f9719a2536f50474e.tar.gz
python3: fix build for shared object
Fixed when build on armv7a_vfp_neon: Python-3.3.3/Modules/_struct.o: relocation R_ARM_MOVW_ABS_NC against `a local symbol' can not be used when making a shared object; recompile with -fPIC All the archs should use -fPIC when build shared object for linux. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3_3.4.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb
index bee9e6f8ec..5ef17e6399 100644
--- a/meta/recipes-devtools/python/python3_3.4.3.bb
+++ b/meta/recipes-devtools/python/python3_3.4.3.bb
@@ -67,6 +67,7 @@ EXTRA_OECONF += "CROSSPYTHONPATH=${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}
export CROSS_COMPILE = "${TARGET_PREFIX}"
export _PYTHON_PROJECT_BASE = "${B}"
export _PYTHON_PROJECT_SRC = "${S}"
+export CCSHARED = "-fPIC"
# No ctypes option for python 3
PYTHONLSBOPTS = ""