aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-06-13 10:40:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-14 08:41:42 +0100
commit23f1dddbf9cf783d90040b67978d1291b16a13de (patch)
treea8dbf89b7e71eaebc5b7b8337fd44d3a30622a8b
parentcbdf390806cf9fb7c0b0141a54abde372514b1cb (diff)
downloadopenembedded-core-contrib-23f1dddbf9cf783d90040b67978d1291b16a13de.tar.gz
e2fsprogs: use update-alt for chattr
Both busybox and e2fsprogs provide chattr, ensure that they are delivered to the same location and use update-alternatives to ensure the correct links are there. [YOCTO #6407] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
index 2bdd7246a2..530255474d 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
@@ -54,6 +54,8 @@ do_install () {
fi
oe_multilib_header ext2fs/ext2_types.h
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
}
RDEPENDS_e2fsprogs = "e2fsprogs-badblocks"
@@ -73,3 +75,10 @@ FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so"
BBCLASSEXTEND = "native"
+
+inherit update-alternatives
+
+ALTERNATIVE_${PN} = "chattr"
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_LINK_NAME[chattr] = "${base_bindir}/chattr"
+ALTERNATIVE_TARGET[chattr] = "${base_bindir}/chattr.e2fsprogs"