aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-04-01 20:09:19 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-03 15:51:09 +0100
commit89705b6ba06b4157b237926e75bb37ff03636944 (patch)
tree50afd394b97e56c5e6d7816214e94b2d27bb0faf
parent28910ee2eacc15cf42b5e58bd43b3bd15c34eb97 (diff)
downloadopenembedded-core-contrib-89705b6ba06b4157b237926e75bb37ff03636944.tar.gz
linux-yocto/4.1: telemetry and dmaengine backports
Backports to support Broxton and Apollo lake: 96c0e80f4007 dmaengine: idma64: clear LLP_[SD]_EN bits in last descriptor 3b2dbd1cadbf dmaengine: idma64: use local variable to index descriptor d61599f94946 dmaengine: idma64: convert idma64_hw_desc_fill() to return void 9c9f37533789 dmaengine: idma64: set maximum allowed segment size for DMA 9d55c9523aa5 dmaengine: idma64: drop IRQ enable / disable in handler f80e3f3f87c5 dmaengine: idma64: use lo_hi_readq() / lo_hi_writeq() 216429c319aa dmaengine: idma64: make better performance on pause / resume 2f982603b358 dmaengine: idma64: this is not DesignWare a7f7ee3a6a91 dmaengine: idma64: useless use of min_t() 3c8f2fcd2dfd dmaengine: idma64: convert to __ffs() b452447dce9f dmaengine: idma64: improve residue estimation 849fdbe687a8 dmaengine: add a driver for Intel integrated DMA 64-bit 0038e6a4798e intel_punit_ipc: add NULL check for input parameters 4bd7fc987da6 platform:x86: Add Intel telemetry platform device 472c405dd66d intel_pmc_ipc: update acpi resource structure for Punit e1754195568b MAINTAINERS: Combine multiple telemetry entries 14d8e14aca6d intel_telemetry_debugfs: Fix unused warnings in telemetry debugfs 8724677a6b60 platform:x86: Add Intel Telemetry Debugfs interfaces d503a325c0ee platform:x86: Add Intel telemetry platform driver 255a8ac345e7 platform/x86: Add Intel Telemetry Core Driver c475943802b5 platform:x86: add Intel P-Unit mailbox IPC driver c2f1b2c7282c MAINTAINERS: Add maintainership for MIC drivers 7d389b483d32 surface pro 3: Add support driver for Surface Pro 3 buttons Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.1.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 48f9f08957..468358b08a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -2,7 +2,7 @@ KBRANCH ?= "standard/preempt-rt/base"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "23325988c373852d75515cfa9582681a036d1bfd"
+SRCREV_machine ?= "7ffcde760a73f672bccb1c43130667d30ba7195c"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 13c30c70cb..12f572cc40 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "afaf425e796c6b72c10e869ea6ad20295033f956"
+SRCREV_machine ?= "96c0e80f4007cce8d4f559a23f7a22da156ccbe2"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.1.bb b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
index 2841aa211c..5f0559f068 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.1.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "4f8fe4c56eb352573a19b797d2c4d1b1f4e38831"
-SRCREV_machine_qemuarm64 ?= "afaf425e796c6b72c10e869ea6ad20295033f956"
-SRCREV_machine_qemumips ?= "85f5c8b85364ea8e7f8d47a492c7047bfd9aa963"
-SRCREV_machine_qemuppc ?= "afaf425e796c6b72c10e869ea6ad20295033f956"
-SRCREV_machine_qemux86 ?= "afaf425e796c6b72c10e869ea6ad20295033f956"
-SRCREV_machine_qemux86-64 ?= "afaf425e796c6b72c10e869ea6ad20295033f956"
-SRCREV_machine_qemumips64 ?= "8ac723e2fb023bd3b168d3fb914c09797bc20ed4"
-SRCREV_machine ?= "afaf425e796c6b72c10e869ea6ad20295033f956"
+SRCREV_machine_qemuarm ?= "ecabd4f1cf9b1e6279943c8e93eff58095296fb6"
+SRCREV_machine_qemuarm64 ?= "96c0e80f4007cce8d4f559a23f7a22da156ccbe2"
+SRCREV_machine_qemumips ?= "8fd9efe95598ddf89ec432a967a38f02b2906a8b"
+SRCREV_machine_qemuppc ?= "96c0e80f4007cce8d4f559a23f7a22da156ccbe2"
+SRCREV_machine_qemux86 ?= "96c0e80f4007cce8d4f559a23f7a22da156ccbe2"
+SRCREV_machine_qemux86-64 ?= "96c0e80f4007cce8d4f559a23f7a22da156ccbe2"
+SRCREV_machine_qemumips64 ?= "cb16b5365e26e106d56a6f8ed23eb8b57905ecf8"
+SRCREV_machine ?= "96c0e80f4007cce8d4f559a23f7a22da156ccbe2"
SRCREV_meta ?= "b9023d4c8fbbb854c26f158a079a5f54dd61964d"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;name=machine;branch=${KBRANCH}; \